package/minidlna: Fix static compile
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 24 Jul 2015 18:38:27 +0000 (20:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Jul 2015 13:17:08 +0000 (15:17 +0200)
Fixes
http://autobuild.buildroot.net/results/aeb/aeb5481526497a01ada8ee9403f282a2374b0383/
http://autobuild.buildroot.net/results/255/25536df514477f3210caf4af27f2f107683f7fb2/
http://autobuild.buildroot.net/results/fa1/fa11cb360190b02d08e74997b0abc73079760dfa/
and many others

This is a follow-up for these patches:
http://patchwork.ozlabs.org/patch/493360/
http://patchwork.ozlabs.org/patch/416007/

[Thomas:
  - don't pass --static to pkg-config, since our pkg-config wrapper
    already passes it automatically when BR2_STATIC_LIBS=y.
  - make only one call to pkg-config for all three libraries
  - put the libintl logic separately from the definition of
    MINIDLNA_CONF_ENV.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/minidlna/minidlna.mk

index 3a9ad416594a6008b6cb9c266a9696483650b72a..ab9348467a929fd679084fba5fe6690ac0184e78 100644 (file)
@@ -17,8 +17,9 @@ MINIDLNA_DEPENDENCIES = \
 ifeq ($(BR2_STATIC_LIBS),y)
 # the configure script / Makefile forgets to link with some of the dependent
 # libraries breaking static linking, so help it along
-MINIDLNA_CONF_ENV = \
-       LIBS='-lavformat -lavcodec -lavutil -logg -lz -lpthread -lm'
+MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libavcodec libexif libvorbis`
+MINIDLNA_STATIC_LIBS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)
+MINIDLNA_CONF_ENV += LIBS="$(MINIDLNA_STATIC_LIBS)"
 else
 MINIDLNA_CONF_OPTS = \
        --disable-static