links: fix static link with directfb
authorBaruch Siach <baruch@tkos.co.il>
Tue, 12 Apr 2016 16:55:36 +0000 (19:55 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 12 Apr 2016 21:22:13 +0000 (23:22 +0200)
The AC_HAVE_FUNCS autoconf macro uses gcc to check for function existence.
This breaks when the library depends on libstdc++, like directfb. Add this
dependency externally.

Fixes:
http://autobuild.buildroot.net/results/548/548019b71c7db649f20d2c479bb8fb3612162d4a/
http://autobuild.buildroot.net/results/c94/c9495f54db388bde9d64325bb57fc4e58741f7a7/
http://autobuild.buildroot.net/results/9b8/9b883d42bff3633f16447d76d2eb4ddf68013788/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/links/links.mk

index 62f91a32e39e1621edadec581f002b6b22c6efc8..ab2b58359965c584af916555c17a9d51953eaf22 100644 (file)
@@ -22,6 +22,9 @@ LINKS_CONF_OPTS += --without-x
 endif
 ifeq ($(BR2_PACKAGE_DIRECTFB),y)
 LINKS_CONF_ENV = ac_cv_path_DIRECTFB_CONFIG=$(STAGING_DIR)/usr/bin/directfb-config
+ifeq ($(BR2_STATIC_LIBS),y)
+LINKS_CONF_ENV += LIBS=-lstdc++
+endif
 LINKS_CONF_OPTS += --with-directfb
 LINKS_DEPENDENCIES += directfb
 else