package/libeXosip2: add optional support for c-ares
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 23:00:25 +0000 (00:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 13:39:10 +0000 (14:39 +0100)
When c-ares was compiled before, libeXosip2 will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/sip_reg | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libcares.so.2]
[...]

The build system offers no option to en-/disable c-ares support:
http://git.savannah.gnu.org/cgit/exosip.git/tree/configure.in?h=exosip-3.X.X#n208

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libeXosip2/libeXosip2.mk

index d7d0af817be798d6fa72df1d9ada1a0b4ccff19a..d101f954786fc4525ce74d9ba5fb17c4044c747a 100644 (file)
@@ -20,6 +20,10 @@ ifeq ($(BR2_arc),y)
 LIBEXOSIP2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
 endif
 
+ifeq ($(BR2_PACKAGE_C_ARES),y)
+LIBEXOSIP2_DEPENDENCIES += c-ares
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBEXOSIP2_DEPENDENCIES += openssl
 LIBEXOSIP2_CONF_OPTS += --enable-openssl