toolchain-external: bump to Linaro ARM 2013.06
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 23 Jun 2013 14:20:02 +0000 (16:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Jun 2013 19:55:42 +0000 (21:55 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 94b8158a9331a64910df319c086af989b0a486f1..ebe9fcd3080c0b069b1cd90ea1f88a55a03b1f40 100644 (file)
@@ -3,8 +3,8 @@ if BR2_TOOLCHAIN_EXTERNAL
 choice
        prompt "Toolchain"
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
-       bool "Linaro 2013.05"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
+       bool "Linaro 2013.06"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -14,7 +14,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GCC 2013.06 (based on gcc 4.8), Linaro GDB 2013.06 (based on
          GDB 7.6), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
@@ -22,8 +22,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
-       bool "Linaro 2013.04"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
+       bool "Linaro 2013.05"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -33,16 +33,16 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
-         GDB 7.5), eglibc 2.15. It generates code that runs on all
+         GCC 2013.05 (based on gcc 4.8), Linaro GDB 2013.05 (based on
+         GDB 7.6), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
          calling convention, and uses the VFPv3-D16 FPU instructions.
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
-       bool "Linaro 2013.03"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
+       bool "Linaro 2013.04"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
@@ -52,7 +52,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2013.03 (based on gcc 4.7), Linaro GDB 2012.12 (based on
+         GCC 2013.04 (based on gcc 4.7), Linaro GDB 2012.12 (based on
          GDB 7.5), eglibc 2.15. It generates code that runs on all
          Cortex-A profile devices, but tuned for the Cortex-A9. The
          code generated is Thumb 2, with the hard floating point
@@ -777,9 +777,9 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
index e5dc8ed4106b8e4b7c243620dae524ba4c0d0001..2b0b23ec84dea4ebc2d9e3360e9f040bda1ab5f9 100644 (file)
@@ -218,15 +218,15 @@ define TOOLCHAIN_EXTERNAL_FIXUP_CMDS
        mv $(@D)/arago-2011.09/armv5te/* $(@D)/
        rm -rf $(@D)/arago-2011.09/
 endef
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03),y)
-TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.03/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.03-20130313_linux.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_04),y)
 TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.04/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2013.04-20130415_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_05),y)
 TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.05/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.8-2013.05_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_06),y)
+TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.06/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.8-2013.06_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2012.03-63-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2