webkit: Add --enable-dependency-tracking to the configure options
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 6 Nov 2014 18:03:56 +0000 (18:03 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 22:04:54 +0000 (23:04 +0100)
--disable-dependency-tracking was added globally to
package/pkg-autotools.mk by this commit:

http://git.buildroot.net/buildroot/commit/?id=3e37b0fc6cbbe2245e39fedb247a381fb4e0d992

This causes a failure in webkit because some source files are generated
after the Makefile is created. To fix this, we add
--enable-dependency-tracking to the configure options.

Fixes:
  http://autobuild.buildroot.net/results/5beea967b02df202bca1d42afd6fa8c2c13383d5/

Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webkit/webkit.mk

index fae2e7e413105679d508473ba3e3f57141312dd9..98da1d6787ff2353936217b1b4c0365aa60bd62e 100644 (file)
@@ -40,6 +40,7 @@ WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
        AR_FLAGS="cru"
 
 WEBKIT_CONF_OPTS += \
+       --enable-dependency-tracking \
        --with-gtk=2.0 \
        --disable-geolocation \
        --disable-webkit2 \