Makefile: move KERNEL_ARCH from kernel-headers to here
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Oct 2010 21:32:37 +0000 (23:32 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Oct 2010 21:32:37 +0000 (23:32 +0200)
Closes #2707

It's not only for kernel headers, and the kernel headers .mk file
isn't included for crosstool-ng toolchain, which broke linux/u-boot/..
builds.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
Makefile
toolchain/kernel-headers/kernel-headers.mk

diff --git a/CHANGES b/CHANGES
index 21fffdecf97a7304b2380909bc68f86ac0193a5e..9adcc91fb7800b251d8e00b1ccb5b91c6bd5242a 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -68,6 +68,7 @@
        #2521: Can't compile sdl_mixer, mikmod.h can't be found
        #2563: [PATCH] cairo: Expose the configure option to disable some...
        #2581: libmms: Update to 0.6, and patch to work on architectures...
+       #2707: Can't compile linux kernel using buildroot + crosstool-ng
 
 2010.08: Released August 31th, 2010:
 
index ac60b24eeb49233931d188175e34c281374b07ff..22c3801d111a3f943bc0579927d9287f72d96a8d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -249,6 +249,14 @@ ifeq ($(ARCH),xtensa)
 ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
 endif
 
+KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
+       -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+       -e s/arm.*/arm/ -e s/sa110/arm/ \
+       -e s/parisc64/parisc/ \
+       -e s/powerpc64/powerpc/ \
+       -e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
+       -e s/sh.*/sh/)
+
 ZCAT:=$(call qstrip,$(BR2_ZCAT))
 BZCAT:=$(call qstrip,$(BR2_BZCAT))
 TAR_OPTIONS=$(call qstrip,$(BR2_TAR_OPTIONS)) -xf
index 7b8989bbce86b8d62e4d8aa177138f964620d23e..bb7ee3c4001722fd12270d85742137b37e7292d7 100644 (file)
@@ -13,14 +13,6 @@ LINUX_HEADERS_SITE:=127.0.0.1
 LINUX_HEADERS_SOURCE:=unspecified-kernel-headers
 LINUX_HEADERS_UNPACK_DIR:=$(TOOLCHAIN_DIR)/linux-libc-headers-null
 
-KERNEL_ARCH:=$(shell $(SHELL) -c "echo \"$(ARCH)\" | sed -e \"s/-.*//\" \
-       -e s/i.86/i386/ -e s/sun4u/sparc64/ \
-       -e s/arm.*/arm/ -e s/sa110/arm/ \
-       -e s/parisc64/parisc/ \
-       -e s/powerpc64/powerpc/ \
-       -e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
-       -e s/sh.*/sh/")
-
 include toolchain/kernel-headers/kernel-headers-new.makefile
 
 $(DL_DIR)/$(LINUX_HEADERS_SOURCE):