package/bind: remove threads dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 26 Apr 2019 16:56:11 +0000 (18:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 9 May 2019 19:25:15 +0000 (21:25 +0200)
Threads dependency has been added in 2015 with commit
07c1ad4647b6a8e60338fc01ddcb2d629de0ad14 however bind can be built
without threads thanks to --disable-threads

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bind/Config.in
package/bind/bind.mk

index 5b34b66f7abc299b9d4f7d3e9804bcabf6fa056c..60546f691bf1a892d17b3a60b2c0af04a7581ff0 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_BIND
        bool "bind"
        depends on BR2_USE_MMU # fork()
-       depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          BIND (Berkeley Internet Name Domain) is an
          implementation of the Domain Name System (DNS) protocols
@@ -39,7 +38,3 @@ config BR2_PACKAGE_BIND_TOOLS
          Install tools (dig, host, nslookup, nsupdate)
 
 endif
-
-comment "bind needs a toolchain w/ threads"
-       depends on BR2_USE_MMU
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
index 9d1f5a1ecbb5ff4c1a4d0356b5bfbdb562cc3cc8..feec6fe27dea01d57be95fc5421de7983f2dffb5 100644 (file)
@@ -24,6 +24,7 @@ BIND_CONF_ENV = \
        BUILD_CC="$(TARGET_CC)" \
        BUILD_CFLAGS="$(TARGET_CFLAGS)"
 BIND_CONF_OPTS = \
+       $(if $(BR2_TOOLCHAIN_HAS_THREADS),--enable-threads,--disable-threads) \
        --without-lmdb \
        --with-libjson=no \
        --with-randomdev=/dev/urandom \