heirloom-mailx: run makeconfig in configure step
authorArnout Vandecappelle <arnout@mind.be>
Sat, 12 May 2012 23:44:18 +0000 (23:44 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 May 2012 19:19:10 +0000 (21:19 +0200)
The heirloom-mailx Makefile runs makeconfig if this has not been done
before.  In a parallel build, this means makeconfig may be run several
times in parallel because there are two targets that depend on makeconfig.
See for instance
http://autobuild.buildroot.net/results/d24854be69961f71db189f9d804d4bd2cfa078da

To avoid this, run makeconfig in the configure step, which is not parallel.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/heirloom-mailx/heirloom-mailx.mk

index 2b28a3fc401ef3d51a9817b3aef5430604380042..b1779c0bb1cd805cd1eeddc9193f85bcfc51587f 100644 (file)
@@ -12,6 +12,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
 HEIRLOOM_MAILX_DEPENDENCIES += openssl
 endif
 
+define HEIRLOOM_MAILX_CONFIGURE_CMDS
+       (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(SHELL) ./makeconfig)
+endef
+
 define HEIRLOOM_MAILX_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
 endef