blktrace: re-enable on uClibc
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Aug 2016 14:40:00 +0000 (16:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 26 Aug 2016 13:59:54 +0000 (15:59 +0200)
With a small patch, blktrace can work on uClibc: we simply need to link
with librt to use the posix_spawn*() functions.

[Thomas: add reference to upstream commit.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/blktrace/0001-iowatcher-link-with-lrt.patch [new file with mode: 0644]
package/blktrace/Config.in

diff --git a/package/blktrace/0001-iowatcher-link-with-lrt.patch b/package/blktrace/0001-iowatcher-link-with-lrt.patch
new file mode 100644 (file)
index 0000000..689a678
--- /dev/null
@@ -0,0 +1,31 @@
+From 80d87b99d72034441ea4fbab81f5c80c1ef3b067 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Tue, 23 Aug 2016 16:36:14 +0200
+Subject: [PATCH] iowatcher: link with -lrt
+
+Some C libraries (notably uClibc) have the posix_spawn*() functions in
+librt, so let's link iowatcher with -lrt.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Upstream-status: merged
+ (http://git.kernel.org/cgit/linux/kernel/git/axboe/blktrace.git/commit/?id=d1ab783430f5a832e973ed9a293da146c04c6702)
+---
+ iowatcher/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/iowatcher/Makefile b/iowatcher/Makefile
+index 7b5101c..502476d 100644
+--- a/iowatcher/Makefile
++++ b/iowatcher/Makefile
+@@ -19,7 +19,7 @@ all: $(ALL)
+       $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+ iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
+ depend:
+       @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend
+-- 
+2.7.4
+
index 958f004d1142e28af644270efddd728d67e4e9a2..38c0947e1c3dcfa8e070ea1284e66bd6ccde5b60 100644 (file)
@@ -1,7 +1,5 @@
 config BR2_PACKAGE_BLKTRACE
        bool "blktrace"
-       # Uses posix_spawn()
-       depends on BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_PACKAGE_LIBAIO_ARCH_SUPPORTS
        select BR2_PACKAGE_LIBAIO
        help
@@ -10,6 +8,3 @@ config BR2_PACKAGE_BLKTRACE
          up to user space.
 
          http://git.kernel.dk/?p=blktrace.git;a=summary
-
-comment "blktrace needs a glibc or musl toolchain"
-       depends on !(BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL)