libsoc: add host-pkgconf dependency
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 3 Apr 2017 08:14:41 +0000 (10:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Apr 2017 12:31:05 +0000 (14:31 +0200)
Without pkg-config PKG_CHECK_MODULES won't be expanded
and ./configure script produces following error message:

./configure: line 12237: syntax error near unexpected token `PYTHON,'
./configure: line 12237: ` PKG_CHECK_MODULES(PYTHON, python-"$PYTHON_VERSION")'

Fixes:

http://autobuild.buildroot.net/results/86e/86e04bd2b10527130306451e56a7693ed4b4befd

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsoc/libsoc.mk

index 19a8c424a960b6ac3a69ad2d0903a5b2bbf22d4a..bbc33143cccffbf19e4d34a093db4760028ecf6e 100644 (file)
@@ -10,6 +10,7 @@ LIBSOC_LICENSE = LGPL-2.1
 LIBSOC_LICENSE_FILES = LICENCE
 LIBSOC_AUTORECONF = YES
 LIBSOC_INSTALL_STAGING = YES
+LIBSOC_DEPENDENCIES = host-pkgconf
 
 # Install Python 2 bindings
 ifeq ($(BR2_PACKAGE_PYTHON),y)