package: add Boehm-Demers-Weiser gc library
authoralex.bennee@linaro.org <alex.bennee@linaro.org>
Fri, 11 Apr 2014 14:05:55 +0000 (15:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Apr 2014 17:00:29 +0000 (19:00 +0200)
This is needed for applications like Zile

[Thomas:
 - use $(...) instead of ${...} to reference LIBGC_VERSION
 - add missing dependency on libatomic_ops dependencies
 - fix DEPENDANCIES -> DEPENDENCIES
 - replace += by = in dependencies definition
 - add host-pkgconf to the list of dependencies
 - fix license, it's a X11-style permissive license
 - fix license file, COPYING didn't exist, use README.md instead]

Signed-off-by: Alex Bennée <alex.bennee@linaro.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libgc/Config.in [new file with mode: 0644]
package/libgc/libgc.mk [new file with mode: 0644]

index 01c7ae949adc2947af85b4c082a741d1e69aed79..51f25159d884cddd6b2ed7594cc38ff0c6bd3ef2 100644 (file)
@@ -792,6 +792,7 @@ source "package/libev/Config.in"
 source "package/libevdev/Config.in"
 source "package/libevent/Config.in"
 source "package/libffi/Config.in"
+source "package/libgc/Config.in"
 source "package/libglib2/Config.in"
 source "package/libical/Config.in"
 source "package/libnspr/Config.in"
diff --git a/package/libgc/Config.in b/package/libgc/Config.in
new file mode 100644 (file)
index 0000000..5e23b3d
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBGC
+       bool "libgc"
+       select BR2_PACKAGE_LIBATOMIC_OPS
+       depends on BR2_PACKAGE_LIBATOMIC_ARCH_SUPPORTS
+       help
+         The Boehm-Demers-Weiser conservative garbage collector can be used
+         as a garbage collecting replacement for C malloc or C++ new. It allows
+         you to allocate memory basically as you normally would, without
+         explicitly deallocating memory that is no longer useful.
+
+         http://www.hboehm.info/gc/
diff --git a/package/libgc/libgc.mk b/package/libgc/libgc.mk
new file mode 100644 (file)
index 0000000..a8611f1
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libgc
+#
+################################################################################
+
+LIBGC_VERSION = 7.4.0
+LIBGC_SOURCE = gc-$(LIBGC_VERSION).tar.gz
+LIBGC_SITE = http://www.hboehm.info/gc/gc_source/
+LIBGC_DEPENDENCIES = libatomic_ops host-pkgconf
+LIBGC_LICENSE = Permissive X11-style
+LIBGC_LICENSE_FILES = README.md
+LIBGC_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))