package/kodi: not available using a musl-based toolchain
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 22:09:13 +0000 (23:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 22:46:11 +0000 (23:46 +0100)
The build stops with
configure: error: unsupported host (i586-buildroot-linux-musl)
due to musl not being supported in
https://github.com/xbmc/xbmc/blob/Isengard/m4/xbmc_arch.m4

Removing this obstacle will show that musl is really not being
supported, the build will fail:

In file included from emu_msvcrt.cpp:64:0:
emu_msvcrt.h:93:3: error: â€˜__off64_t’ does not name a type
   __off64_t dll_lseeki64(int fd, __off64_t lPos, int iWhence);
   ^
emu_msvcrt.h:94:3: error: â€˜__off_t’ does not name a type
   __off_t dll_lseek(int fd, __off_t lPos, int iWhence);
   ^

I know these problems are fixable and the voidlinux projects seems to
have done it already for 15.2-Isengard:
https://github.com/voidlinux/void-packages/tree/99f74705bc6520297d689fae4bcc9606c71ad34f/srcpkgs/kodi/patches

For Jarvis-16.0 these patches have to be rebased at a later stage.
For now block the Kodi package with musl-based toolchains to avoid
build errors.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in

index 23468ccb2967115e491f9b310403ee00c7cb6f2f..13be622406f0a299a78c48a443ca66575dd8a815 100644 (file)
@@ -2,11 +2,12 @@ config BR2_PACKAGE_KODI_ARCH_SUPPORTS
        bool
        default y if (BR2_arm || (BR2_mipsel && BR2_TOOLCHAIN_USES_GLIBC) || BR2_i386 || BR2_x86_64) && BR2_PACKAGE_BOOST_ARCH_SUPPORTS
 
-comment "kodi needs a toolchain w/ C++, threads, wchar, dynamic library, gcc >= 4.7"
+comment "kodi needs a uClibc or (e)glibc toolchain w/ C++, threads, wchar, dynamic library, gcc >= 4.7"
        depends on BR2_PACKAGE_KODI_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS \
                || !BR2_USE_WCHAR || BR2_STATIC_LIBS \
-               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 \
+               || BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_USE_MMU
 
 config BR2_PACKAGE_KODI_EGL_GLES
@@ -92,6 +93,7 @@ menuconfig BR2_PACKAGE_KODI
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_PACKAGE_KODI_EGL_GLES || BR2_PACKAGE_KODI_GL
        depends on BR2_USE_MMU # python
        depends on BR2_USE_WCHAR