This is a rather unusual feature that packagers will not expect.
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
+[baruch: update for 4.6.2]
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
Makefile.in | 4 ----
1 file changed, 4 deletions(-)
@@ -83,12 +83,9 @@ screen: $(OFILES)
$(OPTIONS) $(CFLAGS) $<
- install_bin: .version screen
+ install_bin: .version screen installdirs
- -if [ -f $(DESTDIR)$(bindir)/$(SCREEN) ] && [ ! -f $(DESTDIR)$(bindir)/$(SCREEN).old ]; \
- then mv $(DESTDIR)$(bindir)/$(SCREEN) $(DESTDIR)$(bindir)/$(SCREEN).old; fi
$(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
+++ /dev/null
-From: Maarten ter Huurne <maarten@treewalker.org>
-Date: Mon, 15 Sep 2014 02:27:09 +0200
-Subject: Ensure that installation dirs exist before copying files into them
-
-Since the "install_bin" target requires the installation directories
-to exist, it should depend on the "installdirs" target. The previous
-approach of having "install" depend on "installdirs" is not reliable.
-
-For example, in a parallel build, there was no guarantee that
-"installdirs" would be finished before "install_bin" runs. Also if
-the user requested only "install_bin" to be made, "installdirs" would
-be skipped altogether.
-
-Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
----
- Makefile.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index 860f351..f0fe08d 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -82,7 +82,7 @@ screen: $(OFILES)
- $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
- $(OPTIONS) $(CFLAGS) $<
-
--install_bin: .version screen
-+install_bin: .version screen installdirs
- $(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
- -chown root $(DESTDIR)$(bindir)/$(SCREEN)
- -chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
-@@ -94,7 +94,7 @@ endif
- cp $(srcdir)/utf8encodings/?? $(DESTDIR)$(SCREENENCODINGS)
-
- ###############################################################################
--install: installdirs install_bin
-+install: install_bin
- cd doc ; $(MAKE) install
- -if [ -d /usr/lib/terminfo ]; then \
- PATH="$$PATH:/usr/5bin" tic ${srcdir}/terminfo/screeninfo.src; \
---
-1.8.4.5
-
--- /dev/null
+From: Maarten ter Huurne <maarten@treewalker.org>
+Date: Mon, 15 Sep 2014 00:24:41 +0200
+Subject: Renamed sched.h to eventqueue.h
+
+There is a <sched.h> system header that got shadowed by "sched.h".
+While Screen itself doesn't include <sched.h>, other system headers
+might include it indirectly. This broke the build when using uClibc
+with pthread support.
+
+Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
+---
+ eventqueue.h | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
+ sched.h | 48 ------------------------------------------------
+ screen.h | 2 +-
+ 3 files changed, 49 insertions(+), 49 deletions(-)
+ create mode 100644 eventqueue.h
+ delete mode 100644 sched.h
+
+diff --git a/eventqueue.h b/eventqueue.h
+new file mode 100644
+index 0000000..fdc3fc4
+--- /dev/null
++++ b/eventqueue.h
+@@ -0,0 +1,48 @@
++/* Copyright (c) 2008, 2009
++ * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
++ * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
++ * Micah Cowan (micah@cowan.name)
++ * Sadrul Habib Chowdhury (sadrul@users.sourceforge.net)
++ * Copyright (c) 1993-2002, 2003, 2005, 2006, 2007
++ * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
++ * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
++ * Copyright (c) 1987 Oliver Laumann
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 3, or (at your option)
++ * any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program (see the file COPYING); if not, see
++ * http://www.gnu.org/licenses/, or contact Free Software Foundation, Inc.,
++ * 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301 USA
++ *
++ ****************************************************************
++ * $Id$ GNU
++ */
++
++struct event
++{
++ struct event *next;
++ void (*handler) __P((struct event *, char *));
++ char *data;
++ int fd;
++ int type;
++ int pri;
++ struct timeval timeout;
++ int queued; /* in evs queue */
++ int active; /* in fdset */
++ int *condpos; /* only active if condpos - condneg > 0 */
++ int *condneg;
++};
++
++#define EV_TIMEOUT 0
++#define EV_READ 1
++#define EV_WRITE 2
++#define EV_ALWAYS 3
+diff --git a/sched.h b/sched.h
+deleted file mode 100644
+index fdc3fc4..0000000
+--- a/sched.h
++++ /dev/null
+@@ -1,48 +0,0 @@
+-/* Copyright (c) 2008, 2009
+- * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
+- * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
+- * Micah Cowan (micah@cowan.name)
+- * Sadrul Habib Chowdhury (sadrul@users.sourceforge.net)
+- * Copyright (c) 1993-2002, 2003, 2005, 2006, 2007
+- * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
+- * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
+- * Copyright (c) 1987 Oliver Laumann
+- *
+- * This program is free software; you can redistribute it and/or modify
+- * it under the terms of the GNU General Public License as published by
+- * the Free Software Foundation; either version 3, or (at your option)
+- * any later version.
+- *
+- * This program is distributed in the hope that it will be useful,
+- * but WITHOUT ANY WARRANTY; without even the implied warranty of
+- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+- * GNU General Public License for more details.
+- *
+- * You should have received a copy of the GNU General Public License
+- * along with this program (see the file COPYING); if not, see
+- * http://www.gnu.org/licenses/, or contact Free Software Foundation, Inc.,
+- * 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301 USA
+- *
+- ****************************************************************
+- * $Id$ GNU
+- */
+-
+-struct event
+-{
+- struct event *next;
+- void (*handler) __P((struct event *, char *));
+- char *data;
+- int fd;
+- int type;
+- int pri;
+- struct timeval timeout;
+- int queued; /* in evs queue */
+- int active; /* in fdset */
+- int *condpos; /* only active if condpos - condneg > 0 */
+- int *condneg;
+-};
+-
+-#define EV_TIMEOUT 0
+-#define EV_READ 1
+-#define EV_WRITE 2
+-#define EV_ALWAYS 3
+diff --git a/screen.h b/screen.h
+index 603ca3f..34238c8 100644
+--- a/screen.h
++++ b/screen.h
+@@ -43,7 +43,7 @@
+ #include "osdef.h"
+
+ #include "ansi.h"
+-#include "sched.h"
++#include "eventqueue.h"
+ #include "acls.h"
+ #include "comm.h"
+ #include "layer.h"
+--
+1.8.4.5
+
+++ /dev/null
-From: Maarten ter Huurne <maarten@treewalker.org>
-Date: Mon, 15 Sep 2014 00:24:41 +0200
-Subject: Renamed sched.h to eventqueue.h
-
-There is a <sched.h> system header that got shadowed by "sched.h".
-While Screen itself doesn't include <sched.h>, other system headers
-might include it indirectly. This broke the build when using uClibc
-with pthread support.
-
-Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
----
- eventqueue.h | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
- sched.h | 48 ------------------------------------------------
- screen.h | 2 +-
- 3 files changed, 49 insertions(+), 49 deletions(-)
- create mode 100644 eventqueue.h
- delete mode 100644 sched.h
-
-diff --git a/eventqueue.h b/eventqueue.h
-new file mode 100644
-index 0000000..fdc3fc4
---- /dev/null
-+++ b/eventqueue.h
-@@ -0,0 +1,48 @@
-+/* Copyright (c) 2008, 2009
-+ * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
-+ * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
-+ * Micah Cowan (micah@cowan.name)
-+ * Sadrul Habib Chowdhury (sadrul@users.sourceforge.net)
-+ * Copyright (c) 1993-2002, 2003, 2005, 2006, 2007
-+ * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
-+ * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
-+ * Copyright (c) 1987 Oliver Laumann
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License as published by
-+ * the Free Software Foundation; either version 3, or (at your option)
-+ * any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program (see the file COPYING); if not, see
-+ * http://www.gnu.org/licenses/, or contact Free Software Foundation, Inc.,
-+ * 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301 USA
-+ *
-+ ****************************************************************
-+ * $Id$ GNU
-+ */
-+
-+struct event
-+{
-+ struct event *next;
-+ void (*handler) __P((struct event *, char *));
-+ char *data;
-+ int fd;
-+ int type;
-+ int pri;
-+ struct timeval timeout;
-+ int queued; /* in evs queue */
-+ int active; /* in fdset */
-+ int *condpos; /* only active if condpos - condneg > 0 */
-+ int *condneg;
-+};
-+
-+#define EV_TIMEOUT 0
-+#define EV_READ 1
-+#define EV_WRITE 2
-+#define EV_ALWAYS 3
-diff --git a/sched.h b/sched.h
-deleted file mode 100644
-index fdc3fc4..0000000
---- a/sched.h
-+++ /dev/null
-@@ -1,48 +0,0 @@
--/* Copyright (c) 2008, 2009
-- * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
-- * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
-- * Micah Cowan (micah@cowan.name)
-- * Sadrul Habib Chowdhury (sadrul@users.sourceforge.net)
-- * Copyright (c) 1993-2002, 2003, 2005, 2006, 2007
-- * Juergen Weigert (jnweiger@immd4.informatik.uni-erlangen.de)
-- * Michael Schroeder (mlschroe@immd4.informatik.uni-erlangen.de)
-- * Copyright (c) 1987 Oliver Laumann
-- *
-- * This program is free software; you can redistribute it and/or modify
-- * it under the terms of the GNU General Public License as published by
-- * the Free Software Foundation; either version 3, or (at your option)
-- * any later version.
-- *
-- * This program is distributed in the hope that it will be useful,
-- * but WITHOUT ANY WARRANTY; without even the implied warranty of
-- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- * GNU General Public License for more details.
-- *
-- * You should have received a copy of the GNU General Public License
-- * along with this program (see the file COPYING); if not, see
-- * http://www.gnu.org/licenses/, or contact Free Software Foundation, Inc.,
-- * 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301 USA
-- *
-- ****************************************************************
-- * $Id$ GNU
-- */
--
--struct event
--{
-- struct event *next;
-- void (*handler) __P((struct event *, char *));
-- char *data;
-- int fd;
-- int type;
-- int pri;
-- struct timeval timeout;
-- int queued; /* in evs queue */
-- int active; /* in fdset */
-- int *condpos; /* only active if condpos - condneg > 0 */
-- int *condneg;
--};
--
--#define EV_TIMEOUT 0
--#define EV_READ 1
--#define EV_WRITE 2
--#define EV_ALWAYS 3
-diff --git a/screen.h b/screen.h
-index 603ca3f..34238c8 100644
---- a/screen.h
-+++ b/screen.h
-@@ -43,7 +43,7 @@
- #include "osdef.h"
-
- #include "ansi.h"
--#include "sched.h"
-+#include "eventqueue.h"
- #include "acls.h"
- #include "comm.h"
- #include "layer.h"
---
-1.8.4.5
-
# Locally calculated after checking pgp signature
-sha256 97db2114dd963b016cd4ded34831955dcbe3251e5eee45ac2606e67e9f097b2d screen-4.5.1.tar.gz
+# https://ftp.gnu.org/gnu/screen/screen-4.6.2.tar.gz.sig
+sha256 1b6922520e6a0ce5e28768d620b0f640a6631397f95ccb043b70b91bb503fa3a screen-4.6.2.tar.gz
+# Locally calculated
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
#
################################################################################
-SCREEN_VERSION = 4.5.1
+SCREEN_VERSION = 4.6.2
SCREEN_SITE = $(BR2_GNU_MIRROR)/screen
SCREEN_LICENSE = GPL-3.0+
SCREEN_LICENSE_FILES = COPYING