openssl: misc fixes
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 5 Mar 2009 13:48:29 +0000 (13:48 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 5 Mar 2009 13:48:29 +0000 (13:48 -0000)
Patch by Gustavo Zacarias <gustavo@zacarias.com.ar>
Closes #151.

* Avoid fips directory completely since it just installs source file cruft
  inlib
* Point openssldir to a more friendly and common /etc/ssl rather than
  /usr/lib/ssl

package/openssl/openssl-0.9.8j-nofips.patch [new file with mode: 0644]
package/openssl/openssl.mk

diff --git a/package/openssl/openssl-0.9.8j-nofips.patch b/package/openssl/openssl-0.9.8j-nofips.patch
new file mode 100644 (file)
index 0000000..7780fa4
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Nura openssl-0.9.8j/Makefile openssl-0.9.8j.nofips/Makefile
+--- openssl-0.9.8j/Makefile    2009-01-07 09:57:01.000000000 -0200
++++ openssl-0.9.8j.nofips/Makefile     2009-03-05 10:10:09.000000000 -0200
+@@ -133,7 +133,7 @@
+ BASEADDR=0xFB00000
+-DIRS=   crypto fips ssl engines apps test tools
++DIRS=   crypto ssl engines apps test tools
+ SHLIBDIRS= crypto ssl
+ # dirs in crypto to build
index 79ba284366a2af564cb5e09b588071db4f7f9b53..67326902c03ca1afbd701594f4719a494982c80e 100644 (file)
@@ -38,7 +38,7 @@ $(OPENSSL_TARGET_CONFIGURE):
                ./Configure \
                        linux-$(OPENSSL_TARGET_ARCH) \
                        --prefix=/usr \
-                       --openssldir=/usr/lib/ssl \
+                       --openssldir=/etc/ssl \
                        threads \
                        shared \
                        no-idea \