package/rcw: new package
authorParesh Chaudhary <paresh.chaudhary@rockwellcollins.com>
Wed, 16 Jan 2019 12:39:52 +0000 (06:39 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 11:56:26 +0000 (12:56 +0100)
This package adds NXP Layerscape and QoriQ reset config word
(RCW) / pre-bootloader (PBL) generation support.

The RCW is used to setup clocking and IO allocations and then launches
the next stage of boot (usually u-boot).

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in.host
package/rcw/Config.in.host [new file with mode: 0644]
package/rcw/rcw.hash [new file with mode: 0644]
package/rcw/rcw.mk [new file with mode: 0644]

index 1f3cc6a888b9a411e046b47c4462abd17714e86a..834b6ed62d01d9ef1c5f65a10d04fda2572ba67e 100644 (file)
@@ -1461,6 +1461,7 @@ F:        package/python-posix-ipc/
 F:     package/python-pypcap/
 F:     package/python-pyrex/
 F:     package/raptor/
+F:     package/rcw/
 F:     package/rng-tools/
 F:     package/rsyslog/
 F:     package/setools/
index 3b75f23dd7819407a940a03d9caf894c2f9e940f..b4c501a33b322cc73f725958543c7a1b113d907a 100644 (file)
@@ -53,6 +53,7 @@ menu "Host utilities"
        source "package/qemu/Config.in.host"
        source "package/raspberrypi-usbboot/Config.in.host"
        source "package/rauc/Config.in.host"
+       source "package/rcw/Config.in.host"
        source "package/rustc/Config.in.host"
        source "package/s6-rc/Config.in.host"
        source "package/sam-ba/Config.in.host"
diff --git a/package/rcw/Config.in.host b/package/rcw/Config.in.host
new file mode 100644 (file)
index 0000000..ba40f76
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_HOST_RCW
+       bool "host rcw"
+       help
+         This package provides an reset configuration word(RCW)
+         compiler to build NXP QoriQ/LS PBL/RCW binary(s).
+
+         The package installs example configurations and scripts
+         for each devkit supported in the current release see
+         $(HOST_DIR)/share/rcw. Either a SDK or post scripts can
+         then use this toolset and examples.
+
+         https://source.codeaurora.org/external/qoriq/qoriq-components/rcw/
diff --git a/package/rcw/rcw.hash b/package/rcw/rcw.hash
new file mode 100644 (file)
index 0000000..7de1ec6
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 1421ada9fec10b12ff21cd9ad82f0a835b191cb2dde80f03547764574b1346c3 rcw-LSDK-18.12.tar.gz
+sha256 a531b3146425e592db17a51ff39c4801cb01fb4055ffdaada0572decc0655bcd LICENSE
diff --git a/package/rcw/rcw.mk b/package/rcw/rcw.mk
new file mode 100644 (file)
index 0000000..f4570b9
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# rcw
+#
+################################################################################
+
+RCW_VERSION = LSDK-18.12
+RCW_SITE = https://source.codeaurora.org/external/qoriq/qoriq-components/rcw
+RCW_SITE_METHOD = git
+RCW_LICENSE = BSD-3-Clause
+RCW_LICENSE_FILES = LICENSE
+
+# Copy source files and script into $(HOST_DIR)/share/rcw/ so a developer
+# could use a post image or SDK to build/install PBL files.
+define HOST_RCW_INSTALL_CMDS
+       mkdir -p  $(HOST_DIR)/share/rcw
+       cp -a $(@D)/* $(HOST_DIR)/share/rcw
+endef
+
+$(eval $(host-generic-package))