libnss: Enable for MIPS64 n32 platforms
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 22 May 2014 12:30:46 +0000 (13:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 20:12:52 +0000 (22:12 +0200)
After talking with upstream we concluded that MIPS64 n32 is treated as a
32-bit architecture by libnss because it has 32-bit pointers, so
USE_64=1 should not be set in that case.

Upstream bug:
   https://bugzilla.mozilla.org/show_bug.cgi?id=1010730

WRT:
   http://git.buildroot.net/buildroot/commit/?id=73e6ae0fe6a69f88183ae33401f2314088b5f799

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libnss/Config.in
package/libnss/libnss.mk

index 9a1668c6cb43e9e4c79257c914dd70913053e318..690f928e6d476db8972354e5a651b02be8461c6a 100644 (file)
@@ -6,7 +6,6 @@ config BR2_PACKAGE_LIBNSS
        depends on BR2_LARGEFILE
        depends on BR2_TOOLCHAIN_HAS_THREADS # libnspr
        depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT # libnspr
-       depends on !BR2_MIPS_NABI32
        help
          Network Security Services (NSS) is a set of libraries designed
          to support development of security-enabled client and server
@@ -19,4 +18,3 @@ config BR2_PACKAGE_LIBNSS
 comment "libnss needs a toolchain w/ largefile, threads"
        depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT
        depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
-       depends on !BR2_MIPS_NABI32
index 666df744c7574ba829e5aafe617b34da8962c824..dcbf8bbb739f508d404c2ac34af295af57390dcd 100644 (file)
@@ -30,8 +30,12 @@ LIBNSS_BUILD_VARS = MOZILLA_CLIENT=1 \
                OS_TEST="$(ARCH)"
 
 ifeq ($(BR2_ARCH_IS_64),y)
+# MIPS64 n32 is treated as a 32-bit architecture by libnss.
+# See: https://bugzilla.mozilla.org/show_bug.cgi?id=1010730
+ifeq ($(BR2_MIPS_NABI32),)
 LIBNSS_BUILD_VARS += USE_64=1
 endif
+endif
 
 
 define LIBNSS_BUILD_CMDS