jffs2: cleanup
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 7 Sep 2008 14:31:39 +0000 (14:31 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 7 Sep 2008 14:31:39 +0000 (14:31 -0000)
Patch by Markus Heidelberg <markus.heidelberg@web.de>

* remove needless help in invisible config options
* correct wrong indenting
* remove unused BR2 variables for default pagesize and devfile

target/jffs2/Config.in
target/jffs2/jffs2root.mk

index e30754bc76a9f69b40074f0ae41fc0875a5450d6..23503a93d452aabac35521d61261587da06aa574 100644 (file)
@@ -56,8 +56,6 @@ config BR2_TARGET_ROOTFS_JFFS2_PAGESIZE
        default 0x1000 if BR2_TARGET_ROOTFS_JFFS2_FLASH_128
        default 0x1000 if BR2_TARGET_ROOTFS_JFFS2_FLASH_64
        default $(BR2_TARGET_ROOTFS_JFFS2_CUSTOM_PAGESIZE) if BR2_TARGET_ROOTFS_JFFS2_CUSTOM
-       help
-         Set to pagesize of memory
 
 config BR2_TARGET_ROOTFS_JFFS2_EBSIZE
        hex
@@ -67,8 +65,6 @@ config BR2_TARGET_ROOTFS_JFFS2_EBSIZE
        default 0x20000 if BR2_TARGET_ROOTFS_JFFS2_FLASH_128
        default 0x10000 if BR2_TARGET_ROOTFS_JFFS2_FLASH_64
        default $(BR2_TARGET_ROOTFS_JFFS2_CUSTOM_EBSIZE) if BR2_TARGET_ROOTFS_JFFS2_CUSTOM
-       help
-         Set to Erase Size of memory
 
 config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
        bool "Do not use Cleanmarker"
@@ -114,9 +110,9 @@ config BR2_TARGET_ROOTFS_JFFS2_SQUASH
 config BR2_TARGET_ROOTFS_JFFS2_SUMMARY
        bool "Produce a summarized JFFS2 image"
        depends on BR2_TARGET_ROOTFS_JFFS2
-    help
-      A summarised image can be mounted faster if support is
-      enabled in the kernel (CONFIG_JFFS2_SUMMARY)
+       help
+         A summarised image can be mounted faster if support is
+         enabled in the kernel (CONFIG_JFFS2_SUMMARY)
 
 config BR2_TARGET_ROOTFS_JFFS2_OUTPUT
        string "Output File"
index b58e5d2ad0e638001ea2e780b50976ef701c2770..41b129ddc3d6fbcc0f3e492a70d0606f1e3eb1d4 100644 (file)
@@ -30,19 +30,15 @@ JFFS2_OPTS += -b
 SUMTOOL_OPTS += -b
 endif
 
-ifneq ($(BR2_TARGET_ROOTFS_JFFS2_DEFAULT_PAGESIZE),y)
 JFFS2_OPTS += -s $(BR2_TARGET_ROOTFS_JFFS2_PAGESIZE)
 ifeq ($(BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER),y)
 JFFS2_OPTS += -n
 SUMTOOL_OPTS += -n
 endif
-endif
 
 JFFS2_TARGET := $(strip $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_OUTPUT)))
 #"))
-JFFS2_DEVFILE = $(strip $(subst ",,$(BR2_TARGET_ROOTFS_JFFS2_DEVFILE)))
-#"))
-ifneq ($(JFFS2_DEVFILE)$(TARGET_DEVICE_TABLE),)
+ifneq ($(TARGET_DEVICE_TABLE),)
 JFFS2_OPTS += -D $(TARGET_DEVICE_TABLE)
 endif