libmhash: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 7 Jan 2013 08:12:58 +0000 (08:12 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 13 Jan 2013 20:22:19 +0000 (21:22 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libmhash/Config.in [new file with mode: 0644]
package/libmhash/libmhash.mk [new file with mode: 0644]

index 770d842fcd9649a022b11407df5a17bc956e9c92..01e3694f6808be17e3535ede995b4c5e9ceb9553 100644 (file)
@@ -371,6 +371,7 @@ source "package/beecrypt/Config.in"
 source "package/gnutls/Config.in"
 source "package/libgcrypt/Config.in"
 source "package/libgpg-error/Config.in"
+source "package/libmhash/Config.in"
 source "package/libnss/Config.in"
 source "package/libsha1/Config.in"
 source "package/nettle/Config.in"
diff --git a/package/libmhash/Config.in b/package/libmhash/Config.in
new file mode 100644 (file)
index 0000000..a9bd51a
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBMHASH
+       bool "libmhash"
+       help
+         Mhash is a free (under GNU Lesser GPL) library which provides
+         a uniform interface to a large number of hash algorithms.
+         These algorithms can be used to compute checksums, message digests,
+         and other signatures.
+
+         http://mhash.sourceforge.net/
diff --git a/package/libmhash/libmhash.mk b/package/libmhash/libmhash.mk
new file mode 100644 (file)
index 0000000..aa05f93
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libmhash
+#
+#############################################################
+
+LIBMHASH_VERSION = 0.9.9.9
+LIBMHASH_SITE = http://downloads.sourceforge.net/project/mhash/mhash/$(LIBMHASH_VERSION)
+LIBMHASH_SOURCE = mhash-$(LIBMHASH_VERSION).tar.bz2
+LIBMHASH_INSTALL_STAGING = YES
+LIBMHASH_LICENSE = LGPLv2
+LIBMHASH_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))