package/bearssl: fix BR2_SHARED_STATIC_LIBS case
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Mar 2020 21:27:33 +0000 (22:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Mar 2020 21:27:33 +0000 (22:27 +0100)
Reported-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bearssl/bearssl.mk

index 549b0009165ede473cf771b67e7df7b24a146fd5..e85626153ca750bc1bfafe3a1046cd6104c2d005 100644 (file)
@@ -15,11 +15,11 @@ BEARSSL_MAKE_OPTS = \
        LDDLL=$(TARGET_CC)
 
 ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
-BEARSSL_TARGETS = dll
+BEARSSL_TARGETS += dll
 endif
 
 ifeq ($(BR2_STATIC_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
-BEARSSL_TARGETS = lib
+BEARSSL_TARGETS += lib
 endif
 
 define BEARSSL_BUILD_CMDS