ntp: no longer require openssl
authorAdam Duskett <aduskett@gmail.com>
Tue, 7 Nov 2017 21:29:06 +0000 (16:29 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Nov 2017 12:33:20 +0000 (13:33 +0100)
4.2.8p10 no longer requires openssl to compile.

Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ntp/Config.in
package/ntp/ntp.mk

index 1af02dbc0ba6531631489aba3a7aa23319ea6001..8ce9a5b0bb4ea823f94dca096468f11452e737fa 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_NTP
        bool "ntp"
        select BR2_PACKAGE_LIBEVENT
-       select BR2_PACKAGE_OPENSSL
        help
          Network Time Protocol suite/programs.
          Provides things like ntpd, ntpdate, ntpq, etc...
index c70d6e6351c3fac769e53e4d758fbbf3aaf8e285..6605c3b85b3cb9a8d040037aa19f0bb808ebaff5 100644 (file)
@@ -7,7 +7,7 @@
 NTP_VERSION_MAJOR = 4.2
 NTP_VERSION = $(NTP_VERSION_MAJOR).8p10
 NTP_SITE = https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-$(NTP_VERSION_MAJOR)
-NTP_DEPENDENCIES = host-pkgconf libevent openssl $(if $(BR2_PACKAGE_BUSYBOX),busybox)
+NTP_DEPENDENCIES = host-pkgconf libevent $(if $(BR2_PACKAGE_BUSYBOX),busybox)
 NTP_LICENSE = NTP
 NTP_LICENSE_FILES = COPYRIGHT
 NTP_CONF_ENV = ac_cv_lib_md5_MD5Init=no
@@ -18,12 +18,18 @@ NTP_CONF_OPTS = \
        --disable-debugging \
        --with-yielding-select=yes \
        --disable-local-libevent \
-       --with-crypto
 
 # 0002-ntp-syscalls-fallback.patch
 # 0003-ntpq-fpic.patch
 NTP_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+NTP_CONF_OPTS += --with-crypto
+NTP_DEPENDENCIES += openssl
+else
+NTP_CONF_OPTS += --without-crypto --disable-openssl-random
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_SSP),y)
 NTP_CONF_OPTS += --with-locfile=linux
 else