package/tpm2-totp: explicitly disable optional configure flags
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2019 10:02:33 +0000 (11:02 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2019 10:02:33 +0000 (11:02 +0100)
Explicitly disable doxygen, plymouth, initramfstools and mkinitcpio support
as it is not needed / available in Buildroot.

Also use the new --disable-defaultflags option to ensure our compiler flags
are used rather than trying to disable -fstackprotector-all, similar to how
it is done in tpm2-tss.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-totp/tpm2-totp.mk

index bf298071e18c128dfefe1e7ef8e13047b7c8a25f..a41f899a7103d79bb9b1897dd0c324c802f66998 100644 (file)
@@ -9,11 +9,15 @@ TPM2_TOTP_SITE = https://github.com/tpm2-software/tpm2-totp/releases/download/v$
 TPM2_TOTP_LICENSE = BSD-3-Clause
 TPM2_TOTP_LICENSE_FILES = LICENSE
 TPM2_TOTP_DEPENDENCIES = libqrencode tpm2-tss host-pkgconf
+TPM2_TOTP_CONF_OPTS = \
+       --disable-defaultflags \
+       --disable-doxygen-doc \
+       --disable-plymouth \
+       --without-initramfstoolsdir \
+       --without-mkinitcpiodir
 
-# -fstack-protector-all is used by default. Disable that so the BR2_SSP_* options
-# in the toolchain wrapper and CFLAGS are used instead
-TPM2_TOTP_CONF_ENV += \
-       ax_cv_check_cflags___________Wall__Werror_______fstack_protector_all=no
+# uses C99 code but forgets to pass -std=c99 when --disable-defaultflags is used
+TPM2_TOTP_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99"
 
 # do not build man pages
 TPM2_TOTP_CONF_ENV += ac_cv_path_PANDOC=''