package/qemu: enable sparc64 support in host-qemu
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Sun, 5 May 2019 16:53:54 +0000 (18:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Aug 2019 21:48:49 +0000 (23:48 +0200)
This change enables host qemu support for sparc64 which among other
things allows to test this architecture in gitlab.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/Config.in.host
package/qemu/qemu.mk

index b1c3ab685e4ca1adacc17437624a01c2af2b1010..0287f20514f11ea5951b00d4343dcd227daa5a40 100644 (file)
@@ -17,6 +17,7 @@ config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
        default y if BR2_riscv
        default y if BR2_sh
        default y if BR2_sparc
+       default y if BR2_sparc64
        default y if BR2_x86_64
        depends on !BR2_powerpc_620 && !BR2_powerpc_630 && !BR2_powerpc_970
 
index c5d33d7d3cdcf90382b9f06af5f04365ef643946..f4fa20ababe0d56afc5baf6ef57b232d8deb7126 100644 (file)
@@ -188,6 +188,7 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
 #       sh4aeb          sh4eb
 #       sh64            not supported
 #       sparc           sparc
+#       sparc64         sparc64
 
 HOST_QEMU_ARCH = $(ARCH)
 ifeq ($(HOST_QEMU_ARCH),i486)