{rand,allyes}packageconfig: ensure legacy test options don't get enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Dec 2012 02:10:46 +0000 (18:10 -0800)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Dec 2012 02:13:05 +0000 (18:13 -0800)
The legacy BR2_PACKAGE_* options in Config.in.legacy are not supposed to
be user selectable, so {rand,allyes}packageconfig shouldn't enable them.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index d3f9b40c82eeca5e117b8ac7bdc1e6aa2283abc2..b394fd54fa7b9419f1c68775131a39b20214d589 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -619,6 +619,9 @@ allnoconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
 randpackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
        @grep -v BR2_PACKAGE_ $(CONFIG_DIR)/.config > $(CONFIG_DIR)/.config.nopkg
+       @grep '^config BR2_PACKAGE_' Config.in.legacy | \
+               while read config pkg; do \
+               echo "# $$pkg is not set" >> $(CONFIG_DIR)/.config.nopkg; done
        @$(COMMON_CONFIG_ENV) \
                KCONFIG_ALLCONFIG=$(CONFIG_DIR)/.config.nopkg \
                $< --randconfig $(CONFIG_CONFIG_IN)
@@ -627,6 +630,9 @@ randpackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
 allyespackageconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
        @grep -v BR2_PACKAGE_ $(CONFIG_DIR)/.config > $(CONFIG_DIR)/.config.nopkg
+       @grep '^config BR2_PACKAGE_' Config.in.legacy | \
+               while read config pkg; do \
+               echo "# $$pkg is not set" >> $(CONFIG_DIR)/.config.nopkg; done
        @$(COMMON_CONFIG_ENV) \
                KCONFIG_ALLCONFIG=$(CONFIG_DIR)/.config.nopkg \
                $< --allyesconfig $(CONFIG_CONFIG_IN)