perl: fix build caused by bison generated code
authorFrancois Perrad <fperrad@gmail.com>
Tue, 3 Mar 2015 19:53:06 +0000 (20:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Mar 2015 18:40:13 +0000 (19:40 +0100)
This commit makes sure the date of a C file is newer than the date of
the corresponding Bison source file, so that the build process doesn't
try to regenerate it. This avoids the need to have host-bison as a
dependency for the perl build.

Fixes:

  http://autobuild.buildroot.net/results/1c2/1c261b09f5a4a314d5dcbc1e5811af9c7d18658a/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perl/perl.mk

index 0636abaf546bc0b91ea200904e6f9f6edbb7574f..cd4c2867de1bcc9f51d3e3ca1f05f29d346e2e2d 100644 (file)
@@ -85,6 +85,7 @@ endif
 define PERL_CONFIGURE_CMDS
        (cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_CONF_OPTS))
        $(SED) 's/UNKNOWN-/Buildroot $(BR2_VERSION_FULL) /' $(@D)/patchlevel.h
+       touch $(@D)/x2p/a2p.c # prevents regen by yacc
 endef
 
 define PERL_BUILD_CMDS