rsyslog: install init script and config file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:46 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:25:14 +0000 (00:25 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Also, we take this opportunity to rename RSYSLOG_INSTALL_CONF_SCRIPT
to RSYSLOG_INSTALL_CONF because it is no longer installing an init
script.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rsyslog/rsyslog.mk

index d7dc9303ffb23906030b795ac3bf4a75ce821e5d..6b72bb515cd66a7b0cbfb108b65d5a18a3141c4a 100644 (file)
@@ -39,18 +39,16 @@ else
 endif
 
 define RSYSLOG_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S01rsyslog ] || \
-               $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslog \
-                       $(TARGET_DIR)/etc/init.d/S01rsyslog
+       $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslog \
+               $(TARGET_DIR)/etc/init.d/S01rsyslog
 endef
 
-define RSYSLOG_INSTALL_CONF_SCRIPT
-       [ -f $(TARGET_DIR)/etc/rsyslog.conf ] || \
-               $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
-                       $(TARGET_DIR)/etc/rsyslog.conf
+define RSYSLOG_INSTALL_CONF
+       $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
+               $(TARGET_DIR)/etc/rsyslog.conf
        mkdir -p $(TARGET_DIR)/etc/rsyslog.d
 endef
 
-RSYSLOG_POST_INSTALL_TARGET_HOOKS += RSYSLOG_INSTALL_CONF_SCRIPT
+RSYSLOG_POST_INSTALL_TARGET_HOOKS += RSYSLOG_INSTALL_CONF
 
 $(eval $(autotools-package))