sdl: fix autoreconf timing issue
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 11 Feb 2014 09:12:35 +0000 (10:12 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Feb 2014 09:36:56 +0000 (10:36 +0100)
Context:
The autobuilders were failing on the symbol _XData32 being in conflicts.
A patch had been added to SDL to add a check to the configure.in

Problem:
Sometimes, the build would fail, because of an _XData32 symbol being in
conflicts eventhrough the patch was here.

What was happening:
Following the classic buildroot workflow:
   - Extract
   - [...]
   - Apply 001 patch, which touches configure.in AND configure
   - Apply 002 patch, which touches configure.in
   - Invoke autogen.sh
   - [...]

Right before running autogen.sh, we have configure.in which is more
recent than configure, which is fine.
We then, execute autogen.sh which, basically, runs autoconf.

If your machine was lighty loaded, the time difference between
configure.in and configure was really tiny (ms order), which seems to be
neglected by autoconf.
The results was that the configure was *NOT* generated. And our second
patch was not taken into account.

If your machine was under heavy load, the time difference between the
two files would have been greater and then *maybe* picked up by
autoconf. And then the configure file was re-generated.

When the 0001 patch was introduced, SDL package did *NOT* run it's
autogen.sh, which is why it touches also the configure.
This came later, causing this behavior.

Fixes:
  http://autobuild.buildroot.net/results/d1c/d1c36f634dbf6b6e5d18444c2a23dfd129202b80/

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl/sdl-0001-use-correct-directfb-config.patch

index 225079083fe1a0bf0a0f23f8c24ac0a0f7055a62..ef671a1dddae9152af574dbdb6ca2126074652e6 100644 (file)
@@ -4,13 +4,10 @@ The configure script has just checked for the correct directfb-config
 script, so also use it for the version check instead of whatever
 might be in the path.
 
-Also patch the generated configure, as it doesn't cleanly autoreconf.
-
 Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
 ---
- configure    |    2 +-
  configure.in |    2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
1 files changed, 1 insertions(+), 1 deletions(-)
 
 Index: SDL-1.2.15/configure.in
 ===================================================================
@@ -25,16 +22,4 @@ Index: SDL-1.2.15/configure.in
              HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
              if test $HAVE_VERSION -ge $NEED_VERSION; then
                  DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
-Index: SDL-1.2.15/configure
-===================================================================
---- SDL-1.2.15.orig/configure
-+++ SDL-1.2.15/configure
-@@ -24958,7 +24958,7 @@
-         else
-             set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
-             NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
--            set -- `directfb-config --version | sed 's/\./ /g'`
-+            set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
-             HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
-             if test $HAVE_VERSION -ge $NEED_VERSION; then
-                 DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
+