Revert "dtc: install libfdt library and headers for host variant"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 4 Aug 2016 16:19:18 +0000 (18:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 4 Aug 2016 16:19:18 +0000 (18:19 +0200)
This reverts commit 5ca9b7cf66941a66cff736aadaf8a31afe55f964. Installing
dtc headers in $(HOST_DIR) causes some build failures of
host-uboot-tools due to a conflicting libfdt.h header.

The possible solution to solve this problem, based on -isystem, has been
reverted has it was causing too many issues that we didn't want to solve
so close to cutting 2016.08-rc1.

Since the headers of libfdt for the host are currently not needed for
any package in the Buildroot tree, it is easier and safer to just revert
this patch.

Fixes:

  http://autobuild.buildroot.net/results/9fba77f4080bf6bc26e341f3f383cdba26c0e14f/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dtc/dtc.mk

index febd5920ce0632d51e6ef5085c6c6e868435f5f9..8fdcdbed7766ea5c29f1546ba45a2bcbd3965db9 100644 (file)
@@ -51,9 +51,7 @@ define HOST_DTC_BUILD_CMDS
 endef
 
 define HOST_DTC_INSTALL_CMDS
-       $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin install-lib \
-               install-includes
-
+       $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin
 endef
 
 $(eval $(generic-package))