sdl: build alsa support if enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Jul 2011 21:11:57 +0000 (23:11 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Jul 2011 21:11:57 +0000 (23:11 +0200)
Ensure alsa-lib gets built before SDL if enabled, so the SDL configure
script correctly detects alsa support.

Noticed by Ayla on IRC.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl/sdl.mk

index 99488a60b47153794a730e8fa37eb9ef0711924a..af462c40d6d892fdbe9d0c522846322ed064fd4c 100644 (file)
@@ -40,6 +40,10 @@ ifeq ($(BR2_PACKAGE_TSLIB),y)
 SDL_DEPENDENCIES += tslib
 endif
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+SDL_DEPENDENCIES += alsa-lib
+endif
+
 SDL_CONF_OPT += --enable-pulseaudio=no \
                --disable-arts \
                --disable-esd \