gnupg2: fix build on non-wchar toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Oct 2014 21:14:47 +0000 (23:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Oct 2014 21:14:47 +0000 (23:14 +0200)
The gnupg2 configure script checks whether <stdint.h> complies with
C99. When doing this, it expects a number of WCHAR_* definitions to be
present, which is not the case on non-wchar capable toolchains. The
gnupg2 configure script then concludes that <stdint.h> is not
C99-compliant and generates its own, which causes some build failures
related to intmax_t being not defined.

Since wchar is not actually used in gnupg2, this commit fixes this
problem by forcing gnupg2 to think that our <stdint.h> is
C99-compliant.

Fixes:

  http://autobuild.buildroot.org/results/40f/40fff3bc304e1a83524f28be8f6afc2e217281ad/

And lots of similar issues. Thanks a lot for Romain Naour for the
initial investigation and lots of discussion on IRC about this issue.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
package/gnupg2/gnupg2.mk

index 4b0a26e2541966b62377f60b51073d3d787660e0..71badb609976ca2fc0dcd8648a01270b4e8db653 100644 (file)
@@ -18,6 +18,7 @@ GNUPG2_CONF_OPT = \
        --with-libassuan-prefix=$(STAGING_DIR)/usr \
        --with-ksba-prefix=$(STAGING_DIR)/usr \
        --with-pth-prefix=$(STAGING_DIR)/usr
+GNUPG2_CONF_ENV = gl_cv_header_working_stdint_h=yes
 
 ifneq ($(BR2_PACKAGE_GNUPG2_GPGV2),y)
 define GNUPG2_REMOVE_GPGV2