- add libraw1394, thanks to Lars Munch
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 13 Dec 2006 09:13:15 +0000 (09:13 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 13 Dec 2006 09:13:15 +0000 (09:13 -0000)
package/Config.in
package/libraw1394/Config.in [new file with mode: 0644]
package/libraw1394/libraw1394.mk [new file with mode: 0644]

index e55504098c3022621eb7e04ffb51e8a7aaf98599..61e74e72d27aa32f5a74484456a21a026c867e80 100644 (file)
@@ -75,6 +75,7 @@ source "package/libgtk12/Config.in"
 source "package/libmad/Config.in"
 source "package/libpcap/Config.in"
 source "package/libpng/Config.in"
+source "package/libraw1394/Config.in"
 source "package/libsysfs/Config.in"
 source "package/libtool/Config.in"
 source "package/libusb/Config.in"
diff --git a/package/libraw1394/Config.in b/package/libraw1394/Config.in
new file mode 100644 (file)
index 0000000..859a0b3
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBRAW1394
+       bool "libraw1394"
+       default n
+       help
+               Library for direct access to IEEE 1394 bus.
+
+               Through libraw1394/raw1394, applications can directly
+               send to and receive from other nodes without requiring
+               a kernel driver for the protocol in question.
+
+               http://www.linux1394.org/
diff --git a/package/libraw1394/libraw1394.mk b/package/libraw1394/libraw1394.mk
new file mode 100644 (file)
index 0000000..5eaf80d
--- /dev/null
@@ -0,0 +1,60 @@
+#############################################################
+#
+# libraw1394
+#
+#############################################################
+
+LIBRAW1394_VERSION:=1.2.1
+LIBRAW1394_SOURCE:=libraw1394-$(LIBRAW1394_VERSION).tar.gz
+LIBRAW1394_SITE:=http://www.linux1394.org/dl
+LIBRAW1394_DIR:=$(BUILD_DIR)/libraw1394-$(LIBRAW1394_VERSION)
+
+$(DL_DIR)/$(LIBRAW1394_SOURCE):
+       $(WGET) -P $(DL_DIR) $(LIBRAW1394_SITE)/$(LIBRAW1394_SOURCE)
+
+$(LIBRAW1394_DIR)/.source: $(DL_DIR)/$(LIBRAW1394_SOURCE)
+       $(ZCAT) $(DL_DIR)/$(LIBRAW1394_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(LIBRAW1394_DIR)/.source
+
+$(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.source
+       (cd $(LIBRAW1394_DIR); \
+               $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD="$(HOSTCC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --prefix=$(STAGING_DIR) \
+       );
+       touch $(LIBRAW1394_DIR)/.configured;
+
+$(LIBRAW1394_DIR)/.compiled: $(LIBRAW1394_DIR)/.configured
+       $(MAKE) -C $(LIBRAW1394_DIR)
+       touch $(LIBRAW1394_DIR)/.compiled
+
+$(STAGING_DIR)/lib/libraw1394.so: $(LIBRAW1394_DIR)/.compiled
+       make -C $(LIBRAW1394_DIR)/src install
+
+$(TARGET_DIR)/usr/lib/libraw1394.so: $(STAGING_DIR)/lib/libraw1394.so
+       cp -dpf $(STAGING_DIR)/lib/libraw1394.so* $(TARGET_DIR)/usr/lib/
+
+libraw1394: uclibc $(TARGET_DIR)/usr/lib/libraw1394.so
+
+libraw1394-source: $(DL_DIR)/$(LIBRAW1394_SOURCE)
+
+libraw1394-clean:
+       rm $(TARGET_DIR)/usr/lib/libraw1394.so*
+       -$(MAKE) -C $(LIBRAW1394_DIR) clean
+
+libraw1394-dirclean:
+       rm -rf $(LIBRAW1394_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBRAW1394)),y)
+TARGETS+=libraw1394
+endif
+