linux-backports: use $(TARGET_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Mon, 17 Oct 2016 16:06:51 +0000 (13:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Oct 2016 13:19:24 +0000 (15:19 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-backports/linux-backports.mk

index 58cd50f2c430458ac56cd45838af83d7e49fdbcf..6f599a8a85d76fc0024d44b498f8a6a7e9a1c805 100644 (file)
@@ -46,7 +46,7 @@ LINUX_BACKPORTS_MODULE_MAKE_OPTS = $(LINUX_BACKPORTS_MAKE_OPTS)
 # generated by running silentoldconfig, but that's not the case for
 # linux-backports: it uses a hand-crafted rule to generate that file.
 define LINUX_BACKPORTS_KCONFIG_FIXUP_CMDS
-       $(MAKE) -C $(@D) $(LINUX_BACKPORTS_MAKE_OPTS) backport-include/backport/autoconf.h
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(LINUX_BACKPORTS_MAKE_OPTS) backport-include/backport/autoconf.h
 endef
 
 # Checks to give errors that the user can understand