package/libopenssl: m68x use SMALL_FOOTPRINT mode
authorMatt Weber <matthew.weber@rockwellcollins.com>
Fri, 8 Feb 2019 18:46:59 +0000 (12:46 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 8 Feb 2019 21:39:50 +0000 (22:39 +0100)
OPENSSL_SMALL_FOOTPRINT mode selects alternate paths in the sha512 and
blake2 algorithms which resolves a assembler issue like the following.

/tmp/ccfnLhKQ.s: Assembler messages:
/tmp/ccfnLhKQ.s:11167: Error: value -32790 out of range
make[2]: *** [crypto/blake2/blake2b.o] Error 1

This issue was found after the OpenSSL1.1.x bump.

Fixes
http://autobuild.buildroot.net/results/533e817695cde321b725145112cfd83c092d9d75

Upstream ticket
https://github.com/openssl/openssl/issues/8190

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libopenssl/libopenssl.mk

index 0bfc74ed0ec18cdeede4030ff9bda7a4ba6ffc3d..a845f1da536476f2e1c3d6468b04ba32519c6d14 100644 (file)
@@ -16,9 +16,11 @@ LIBOPENSSL_TARGET_ARCH = generic32
 LIBOPENSSL_CFLAGS = $(TARGET_CFLAGS)
 LIBOPENSSL_PROVIDES = openssl
 
-# relocation truncated to fit: R_68K_GOT16O
 ifeq ($(BR2_m68k_cf),y)
+# relocation truncated to fit: R_68K_GOT16O
 LIBOPENSSL_CFLAGS += -mxgot
+# resolves an assembler "out of range error" with blake2 and sha512 algorithms
+LIBOPENSSL_CFLAGS += -DOPENSSL_SMALL_FOOTPRINT
 endif
 
 ifeq ($(BR2_USE_MMU),)