qextserialport: use 'make install' to install to staging
authorArnout Vandecappelle <arnout@mind.be>
Sun, 20 Nov 2016 22:13:28 +0000 (23:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Nov 2016 21:44:36 +0000 (22:44 +0100)
qmake hardcodes the path to the sysroot in the install commands, so
we can't use it for target. But it's perfectly usable for staging.

By using 'make install', we get:
- the extserialport.prf file is installed to the mkspecs directory and
  libqextserialport.prl in staging/usr/lib, so qmake can do its magic
  and add the necessary compiler options;
- it also works for static build, when *.so files don't exist.

The QExtSerialPort and qextserialport.pc files are created by
Buildroot so they still have to be installed explicitly. Note that
upstream installs in the QtExtSerialPort directory, not QExtSerialPort,
so we follow that decision.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: also adjust 0003-pkgconfig.patch to fix the header path.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qextserialport/0002-main-include.patch
package/qextserialport/0003-pkgconfig.patch
package/qextserialport/qextserialport.mk

index 858f3354d58831cd6346ae8de218d28602b16a46..27f67f65ae86898cda17a095e72c6f2499efbec4 100644 (file)
@@ -1,7 +1,7 @@
 Create a main include file QExtSerialPort
 
 This main include file will be installed in
-<QExtSerialPort/QExtSerialPort> so that Qt applications can use this
+<QtExtSerialPort/QExtSerialPort> so that Qt applications can use this
 library by including header files in a Qt-like style.
 
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
index d67f3fcbb377a918b9098e922ba84002cb0c26b3..bb55ad782eea8e091b0d4e7a03a0a55d2ec41ab2 100644 (file)
@@ -10,7 +10,7 @@ Index: qextserialport-ef4af2a2ee3f/qextserialport.pc
 +prefix=/usr
 +exec_prefix=${prefix}
 +libdir=${prefix}/lib
-+includedir=${prefix}/include/QExtSerialPort
++includedir=${prefix}/include/QtExtSerialPort
 +
 +Name: QtExtSerialPort
 +Description: QtExtSerialPort library
index f48f59689815c5f8b74ecd8a63b1d7df6ee7858e..15cb74cbd4978d8bc558f466ed954d15762e39a4 100644 (file)
@@ -27,10 +27,8 @@ define QEXTSERIALPORT_BUILD_CMDS
 endef
 
 define QEXTSERIALPORT_INSTALL_STAGING_CMDS
-       mkdir -p $(STAGING_DIR)/usr/include/QExtSerialPort
-       cp $(@D)/src/*.h $(STAGING_DIR)/usr/include/QExtSerialPort/
-       cp $(@D)/src/QExtSerialPort $(STAGING_DIR)/usr/include/QExtSerialPort/
-       cp -a $(@D)/*.so* $(STAGING_DIR)/usr/lib/
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
+       cp $(@D)/src/QExtSerialPort $(STAGING_DIR)/usr/include/QtExtSerialPort/
        cp $(@D)/qextserialport.pc $(STAGING_DIR)/usr/lib/pkgconfig/
 endef