strace: fix build for x86_64
authorArnout Vandecappelle <arnout@mind.be>
Tue, 30 Oct 2012 10:59:57 +0000 (10:59 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 30 Oct 2012 21:04:44 +0000 (22:04 +0100)
strace fails to build on x86_64 because stat64 is not available.  This
is because the automatic detection of stat64 in configure is overridden
by buildroot, by setting ac_cv_type_stat64.  Just remove that override -
current strace seems to detect it correctly for non-largefile platforms.

Build-tested on x86_64 (with largefile), ARM (with and without largefile),
sh4, MIPS and ppc-32 (no largefile).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/strace/strace.mk

index 78768489b9fb63857d98a8aa55579a4b23d89e4d..ad1d0422f716ccd99bebbb00537680af3c3d1b3b 100644 (file)
@@ -9,8 +9,7 @@ STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
 STRACE_SITE = http://downloads.sourceforge.net/project/strace/strace/$(STRACE_VERSION)
 
 STRACE_CONF_ENV = ac_cv_header_linux_if_packet_h=yes \
-                 ac_cv_header_linux_netlink_h=yes \
-                 $(if $(BR2_LARGEFILE),ac_cv_type_stat64=yes,ac_cv_type_stat64=no)
+                 ac_cv_header_linux_netlink_h=yes
 
 ifeq ($(BR2_LARGEFILE),y)
 # strace gets confused when lfs mode is forced, so don't