weston: don't forcibly disable simple EGL clients
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 8 Apr 2016 13:35:21 +0000 (10:35 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 8 Apr 2016 20:12:24 +0000 (22:12 +0200)
Only do so when there's no EGL.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/weston/weston.mk

index e3088ffcad6ba4a2db491e0cbda958c76d47339d..1f31097985796d24a398a14d1e4f27ce7f2adfb8 100644 (file)
@@ -16,7 +16,6 @@ WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
 
 WESTON_CONF_OPTS = \
        --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
-       --disable-simple-egl-clients \
        --disable-xwayland \
        --disable-x11-compositor \
        --disable-wayland-compositor \
@@ -53,7 +52,9 @@ ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL)$(BR2_PACKAGE_MESA3D_OPENGL_ES),yy)
 WESTON_CONF_OPTS += --enable-egl
 WESTON_DEPENDENCIES += libegl
 else
-WESTON_CONF_OPTS += --disable-egl
+WESTON_CONF_OPTS += \
+       --disable-egl \
+       --disable-simple-egl-clients
 endif
 
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)