motion: fix sdl-config detection
authorPeter Seiderer <ps.report@gmx.net>
Mon, 17 Oct 2016 20:44:48 +0000 (22:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Oct 2016 10:01:05 +0000 (12:01 +0200)
Overwrite ac_cv_path_CONFIG_SDL in case sdl development is
installed on the host.

Fixes [1]:

  ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/SDL'

[1] http://autobuild.buildroot.net/results/459/4592eb83efa393f77f5ee014f93a271f2313bee6

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/motion/motion.mk

index de29a2a8e2e879644138b02e730eb494970539a6..cf9be7602a0debbca188bb6a082a06b083e94b89 100644 (file)
@@ -54,6 +54,9 @@ endif
 ifeq ($(BR2_PACKAGE_SDL),y)
 MOTION_DEPENDENCIES += sdl
 MOTION_CONF_OPTS += --with-sdl=$(STAGING_DIR)/usr
+# overwrite ac_cv_path_CONFIG_SDL in case sdl development is
+# installed on the host
+MOTION_CONF_ENV += ac_cv_path_CONFIG_SDL=$(STAGING_DIR)/usr/bin/sdl-config
 else
 MOTION_CONF_OPTS += --without-sdl
 endif