graphs: rename user-facing variables
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Feb 2014 15:59:11 +0000 (16:59 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 24 Feb 2014 21:36:50 +0000 (22:36 +0100)
Rename the GRAPH_OUT and GRAPH_ALT variables according to our
recently-agreed naming scheme for user-facing variables:
  - GRAPH_OUT -> BR2_GRAPH_OUT
  - GRAPH_ALT -> BR2_GRAPH_ALT

The documentation part of the rename is handled by Thomas as
part of his manual fixing spree. ;-)

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile
package/pkg-generic.mk

index 502991f6589bb6cace773c8073d8c4e60796a11b..312babd990bd4903bb028ce8544501d0c6820f0b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -136,7 +136,7 @@ endif
 
 # Need that early, before we scan packages
 # Avoids doing the $(or...) everytime
-BR2_GRAPH_OUT := $(or $(GRAPH_OUT),pdf)
+_BR2_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
 
 BUILD_DIR:=$(BASE_DIR)/build
 STAMP_DIR:=$(BASE_DIR)/stamps
@@ -651,18 +651,18 @@ graph-build: $(O)/build/build-time.log
        @install -d $(O)/graphs
        $(foreach o,name build duration,./support/scripts/graph-build-time \
                                        --type=histogram --order=$(o) --input=$(<) \
-                                       --output=$(O)/graphs/build.hist-$(o).$(BR2_GRAPH_OUT) \
-                                       $(if $(GRAPH_ALT),--alternate-colors)$(sep))
+                                       --output=$(O)/graphs/build.hist-$(o).$(_BR2_GRAPH_OUT) \
+                                       $(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
        $(foreach t,packages steps,./support/scripts/graph-build-time \
                                   --type=pie-$(t) --input=$(<) \
-                                  --output=$(O)/graphs/build.pie-$(t).$(BR2_GRAPH_OUT) \
-                                  $(if $(GRAPH_ALT),--alternate-colors)$(sep))
+                                  --output=$(O)/graphs/build.pie-$(t).$(_BR2_GRAPH_OUT) \
+                                  $(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
 
 graph-depends:
        @$(INSTALL) -d $(O)/graphs
        @cd "$(CONFIG_DIR)"; \
        $(TOPDIR)/support/scripts/graph-depends \
-       |dot -T$(BR2_GRAPH_OUT) -o $(O)/graphs/$(@).$(BR2_GRAPH_OUT)
+       |dot -T$(_BR2_GRAPH_OUT) -o $(O)/graphs/$(@).$(_BR2_GRAPH_OUT)
 
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
index 555c3c2e26dd180839ccadfe6ab8d791fca811c9..5efd9ab52da53fd8170a88967b2aa722f7a6b67f 100644 (file)
@@ -470,7 +470,7 @@ $(1)-graph-depends:
                        @$(INSTALL) -d $(O)/graphs
                        @cd "$(CONFIG_DIR)"; \
                        $(TOPDIR)/support/scripts/graph-depends $(1) \
-                       |dot -T$(BR2_GRAPH_OUT) -o $(O)/graphs/$$(@).$(BR2_GRAPH_OUT)
+                       |dot -T$(_BR2_GRAPH_OUT) -o $(O)/graphs/$$(@).$(_BR2_GRAPH_OUT)
 
 $(1)-dirclean:         $$($(2)_TARGET_DIRCLEAN)