gdb: unbreak host/target install step
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Oct 2016 17:32:43 +0000 (19:32 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Oct 2016 17:32:43 +0000 (19:32 +0200)
Commit 12306a81f8edc (gdb: get rid of host-texinfo dependency) tried to
append MAKEINFO=true to the host/target make install arguments, but as the
default values for these are only added when (host-)autotools-package is
evaluated (and only if empty), this effectively drops the default values and
we ended up without the 'install' target and nothing got installed.

To fix this, specify the full install arguments.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index 0e7abfd2a61a24d1cfc635bed36012dcd1565be6..ccf9e4968dc4d9feb337e663ee461f96ccfcf436 100644 (file)
@@ -39,9 +39,9 @@ HOST_GDB_DEPENDENCIES = host-expat host-ncurses
 
 # Disable building documentation
 GDB_MAKE_OPTS += MAKEINFO=true
-GDB_INSTALL_TARGET_OPTS += MAKEINFO=true
+GDB_INSTALL_TARGET_OPTS += MAKEINFO=true DESTDIR=$(TARGET_DIR) install
 HOST_GDB_MAKE_OPTS += MAKEINFO=true
-HOST_GDB_INSTALL_OPTS += MAKEINFO=true
+HOST_GDB_INSTALL_OPTS += MAKEINFO=true install
 
 # Apply the Xtensa specific patches
 XTENSA_CORE_NAME = $(call qstrip, $(BR2_XTENSA_CORE_NAME))