package/avrdude: fix build with kernel < 4.6
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 14 Mar 2021 09:46:41 +0000 (10:46 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Mar 2021 10:38:49 +0000 (11:38 +0100)
Commit 03fa36df7e6a (package/avrdude: Switch to upstream)
unconditionally enabled linuxspi on the assumption that it is available
since linux-2.6.22.

However, avrdude unconditionally uses GPIO and includes linux/gpio.h,
which is only available since kernel 4.6 and:
    https://github.com/torvalds/linux/commit/3c702e9987e261042a07e43460a8148be254412e

Add a Kconfig option, enabled by default for backward compatibility, to
drive whether to enable or disable SPI support.

Fixes:
 - http://autobuild.buildroot.org/results/962a7fcff1e54a0550eafa0cbca780ba8bc8409e

Note: weirdly enough, GPIO support does not use linux/gpio.h; rather it
uses sysfs.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: add a Kconfig option]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/avrdude/Config.in
package/avrdude/avrdude.mk

index fba4253ad86d05a44e33ad1c0ad067672e18bbfd..89558a5ff5c5faf19fa2ddd33711fa5b7408fafb 100644 (file)
@@ -15,6 +15,18 @@ config BR2_PACKAGE_AVRDUDE
 
          https://github.com/kcuzner/avrdude
 
+if BR2_PACKAGE_AVRDUDE
+
+config BR2_PACKAGE_AVRDUDE_SPI
+       bool "SPI support"
+       default y # Backward compatibility
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_6
+
+comment "SPI support needs a toolchain w/ linux headers >= 4.6"
+       depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_6
+
+endif
+
 comment "avrdude needs a uClibc or glibc toolchain w/ threads, wchar, dynamic library, gcc >= 4.9"
        depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR \
                || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 \
index b6754684e143ad39534fc45563ad7acb33f4b9c2..ae623a792994c19b1c60f6d47eb73fe8bfbfae6c 100644 (file)
@@ -13,10 +13,16 @@ AVRDUDE_SUBDIR = avrdude
 # Sources coming from svn, without generated configure and Makefile.in
 # files.
 AVRDUDE_AUTORECONF = YES
-AVRDUDE_CONF_OPTS = --enable-linuxgpio --enable-linuxspi
+AVRDUDE_CONF_OPTS = --enable-linuxgpio
 AVRDUDE_DEPENDENCIES = elfutils libusb libusb-compat ncurses \
        host-flex host-bison
 
+ifeq ($(BR2_PACKAGE_AVRDUDE_SPI),y)
+AVRDUDE_CONF_OPTS += --enable-linuxspi
+else
+AVRDUDE_CONF_OPTS += --disable-linuxspi
+endif
+
 ifeq ($(BR2_PACKAGE_LIBFTDI1),y)
 AVRDUDE_DEPENDENCIES += libftdi1
 else ifeq ($(BR2_PACKAGE_LIBFTDI),y)