libnfc-llcp: rename to libllcp and bump version
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 10 Jan 2014 10:06:19 +0000 (10:06 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 11:40:43 +0000 (12:40 +0100)
This package has been renamed upstream to libllcp. Also, the current
package we have in Buildroot fails to compile due to a version bump of
it's main dependence, libnfc. A version bump is required because this
package has been adapted upstream to work with libnfc-1.7.0-rc6.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/libllcp/Config.in [new file with mode: 0644]
package/libllcp/libllcp.mk [new file with mode: 0644]
package/libnfc-llcp/Config.in [deleted file]
package/libnfc-llcp/libnfc-llcp.mk [deleted file]

index 01bf16be96ba6e19cb419dd822ad34a4f88c1008..052641938792d672e11d0ebf01374787b23ebe4c 100644 (file)
@@ -98,6 +98,17 @@ comment "build, or run, in unpredictable ways.               "
 comment "----------------------------------------------------"
 endif
 
+###############################################################################
+config BR2_PACKAGE_LIBNFC_LLCP
+       bool "libnfc-llcp has been removed"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+       select BR2_PACKAGE_LIBNFC
+       select BR2_LEGACY
+       help
+         The 'libnfc-llcp' package has been removed since upstream renamed
+          to 'libllcp'. We have added a new package for 'libllcp' and bumped
+          the version at the same time.
+
 ###############################################################################
 comment "Legacy options removed in 2014.02"
 
index aac6f02f23d9b393093e5f6aa68940683a11f5a1..7257ace721e45dac128fde763bf9543b09c48070 100644 (file)
@@ -570,9 +570,9 @@ source "package/libfreefare/Config.in"
 source "package/libftdi/Config.in"
 source "package/libhid/Config.in"
 source "package/libiqrf/Config.in"
+source "package/libllcp/Config.in"
 source "package/libmbim/Config.in"
 source "package/libnfc/Config.in"
-source "package/libnfc-llcp/Config.in"
 source "package/libqmi/Config.in"
 source "package/libraw1394/Config.in"
 source "package/libserial/Config.in"
diff --git a/package/libllcp/Config.in b/package/libllcp/Config.in
new file mode 100644 (file)
index 0000000..e5b2108
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBLLCP
+       bool "libllcp"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+       select BR2_PACKAGE_LIBNFC
+       help
+         Library extending libnfc with support for Logical Link Control
+         Protocol.
+
+         https://code.google.com/p/libllcp/
diff --git a/package/libllcp/libllcp.mk b/package/libllcp/libllcp.mk
new file mode 100644 (file)
index 0000000..30bbf69
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# libllcp
+#
+################################################################################
+
+LIBLLCP_VERSION = cf0c4b3c9df98851c6092c130192130c3f5a46bd
+LIBLLCP_SITE = https://libllcp.googlecode.com/git/
+LIBLLCP_SITE_METHOD = git
+LIBLLCP_DEPENDENCIES = libnfc
+# There's no ./configure in the repository, so we need to autoreconf
+LIBLLCP_AUTORECONF = YES
+LIBLLCP_INSTALL_STAGING = YES
+LIBLLCP_LICENSE = GPLv3+
+LIBLLCP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))
diff --git a/package/libnfc-llcp/Config.in b/package/libnfc-llcp/Config.in
deleted file mode 100644 (file)
index f557926..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_LIBNFC_LLCP
-       bool "libnfc-llcp"
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
-       select BR2_PACKAGE_LIBNFC
-       help
-         Library extending libnfc with support for Logical Link Control
-         Protocol.
-
-         http://code.google.com/p/nfc-tools/source/browse/trunk/libnfc-llcp/
diff --git a/package/libnfc-llcp/libnfc-llcp.mk b/package/libnfc-llcp/libnfc-llcp.mk
deleted file mode 100644 (file)
index d410b55..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-################################################################################
-#
-# libnfc-llcp
-#
-################################################################################
-
-LIBNFC_LLCP_VERSION = 1103
-LIBNFC_LLCP_SITE = http://nfc-tools.googlecode.com/svn/trunk/libnfc-llcp/
-LIBNFC_LLCP_SITE_METHOD = svn
-LIBNFC_LLCP_DEPENDENCIES = libnfc
-LIBNFC_LLCP_AUTORECONF = YES
-LIBNFC_LLCP_AUTORECONF_OPT = --install --force --verbose
-LIBNFC_LLCP_INSTALL_STAGING = YES
-
-$(eval $(autotools-package))