bandwidthd: incorporate fixes for autobuilders
authorNathaniel Roach <nroach44@gmail.com>
Fri, 15 Aug 2014 00:27:09 +0000 (08:27 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Aug 2014 09:05:44 +0000 (11:05 +0200)
"The build failures of bandwidthd observed in the autobuilders in
relation to libpng are caused by the usage of -L/usr/lib
-L/usr/local/lib in the compiler flags, which leads the configure
script to try to link against a host libpng library."

These issues are fixed by:

* Version bump to -r08
"[patched] the configure.ac script to remove the hardcoded
-L/usr/local/lib and -I/usr/local/include. The bandwidthd package
-was already autoreconfigured, so there is no need to add it."

* "Adding the --without-x option, which ensures that the configure.ac
script will not add -L/usr/lib to the compiler flags (and we anyway
haven't added any sort of X.org support to bandwidthd for the
moment)."
Both fixes by Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bandwidthd/bandwidthd.mk

index 9b1eb32ee75d541d04eacb2468d6c32d3f16c34f..3e11d6abb1e5f5a8e91cae50d49dfc749d990a01 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BANDWIDTHD_VERSION = v2.0.1-auto-r07
+BANDWIDTHD_VERSION = v2.0.1-auto-r08
 BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,$(BANDWIDTHD_VERSION))
 
 # Specified as "any version of the GPL that is current as of your
@@ -15,6 +15,8 @@ BANDWIDTHD_DEPENDENCIES = gd libpng libpcap
 
 BANDWIDTHD_AUTORECONF = YES
 
+BANDWIDTHD_CONF_OPT += --without-x
+
 ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
 BANDWIDTHD_DEPENDENCIES += postgresql
 BANDWIDTHD_CONF_OPT += --with-postgresql-logging=true