package/connman : enable build without gnutls dependency
authorHeiko Abraham <abrahamh@web.de>
Fri, 30 May 2014 15:26:21 +0000 (17:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 30 May 2014 21:12:05 +0000 (23:12 +0200)
- add new configuration option '--enable-wispr' (disabled by default)
- move gnutls dependency to "wispr" config option

[Peter: drop gnutls ref for wchar, tweak help text, simplify .mk]
Signed-off-by: Heiko Abraham <abrahamh@web.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/connman/Config.in
package/connman/connman.mk

index 4a4090fe7655897cb74d6e39eac67cc052aa2838..3d118436fb0c32a50d7058c6a90ffab280205426 100644 (file)
@@ -3,10 +3,9 @@ config BR2_PACKAGE_CONNMAN
        select BR2_PACKAGE_DBUS
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_IPTABLES
-       select BR2_PACKAGE_GNUTLS
        depends on !BR2_avr32 # no inotify_init1
        depends on !BR2_UCLIBC_VERSION_0_9_32
-       depends on BR2_USE_WCHAR # libglib2 and gnutls
+       depends on BR2_USE_WCHAR # libglib2
        depends on BR2_INET_IPV6
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
        depends on BR2_USE_MMU # dbus, libglib2
@@ -26,9 +25,23 @@ config BR2_PACKAGE_CONNMAN_ETHERNET
 config BR2_PACKAGE_CONNMAN_WIFI
        bool "enable WiFi support"
        select BR2_PACKAGE_WPA_SUPPLICANT
+       help
+         Enable WiFi support (scan and static/dhcp interface setup). ConnMan 
+         detect the start of wpa_supplicant automatically.
+
+config BR2_PACKAGE_CONNMAN_WISPR
+       bool "enable WISPr support"
+       select BR2_PACKAGE_GNUTLS
+       help
+         Enable support for Wireless Internet Service Provider
+         roaming (WISPr). A RADIUS server is used to authenticate the
+         subscriber's credentials.
 
 config BR2_PACKAGE_CONNMAN_BLUETOOTH
        bool "enable Bluetooth support"
+       help
+         Enable Bluetooth (PAN profile) support. The start of bluetoothd is 
+         automatically detected and only a runtime dependency. 
 
 config BR2_PACKAGE_CONNMAN_LOOPBACK
        bool "enable loopback support"
index f720d1c646735287c387db8acba81deb07528c5a..fb698c4363b70fea85fa92ce1e2c54544bfe1f22 100644 (file)
@@ -7,7 +7,7 @@
 CONNMAN_VERSION = 1.23
 CONNMAN_SOURCE = connman-$(CONNMAN_VERSION).tar.xz
 CONNMAN_SITE = $(BR2_KERNEL_MIRROR)/linux/network/connman/
-CONNMAN_DEPENDENCIES = libglib2 dbus iptables gnutls
+CONNMAN_DEPENDENCIES = libglib2 dbus iptables
 CONNMAN_INSTALL_STAGING = YES
 CONNMAN_LICENSE = GPLv2
 CONNMAN_LICENSE_FILES = COPYING
@@ -15,6 +15,7 @@ CONNMAN_CONF_OPT += --localstatedir=/var \
        $(if $(BR2_PACKAGE_CONNMAN_DEBUG),--enable-debug,--disable-debug)               \
        $(if $(BR2_PACKAGE_CONNMAN_ETHERNET),--enable-ethernet,--disable-ethernet)      \
        $(if $(BR2_PACKAGE_CONNMAN_WIFI),--enable-wifi,--disable-wifi)                  \
+       $(if $(BR2_PACKAGE_CONNMAN_WISPR),--enable-wispr,--disable-wispr) \
        $(if $(BR2_PACKAGE_CONNMAN_BLUETOOTH),--enable-bluetooth,--disable-bluetooth)   \
        $(if $(BR2_PACKAGE_CONNMAN_LOOPBACK),--enable-loopback,--disable-loopback)      \
        $(if $(BR2_PACKAGE_CONNMAN_NEARD),--enable-neard,--disable-neard) \
@@ -23,7 +24,8 @@ CONNMAN_CONF_OPT += --localstatedir=/var \
 
 CONNMAN_DEPENDENCIES += \
        $(if $(BR2_PACKAGE_CONNMAN_NEARD),neard) \
-       $(if $(BR2_PACKAGE_CONNMAN_OFONO),ofono)
+       $(if $(BR2_PACKAGE_CONNMAN_OFONO),ofono) \
+       $(if $(BR2_PACKAGE_CONNMAN_WISPR),gnutls)
 
 define CONNMAN_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 -D package/connman/S45connman $(TARGET_DIR)/etc/init.d/S45connman