package/thrift: drop unneeded static openssl workaround
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Apr 2019 08:38:58 +0000 (10:38 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 13 Apr 2019 14:29:52 +0000 (16:29 +0200)
thrift uses pkg-config to find openssl dependencies such as lz or
latomic so drop unneeded workaround. This was a leftover from the very
first integration of thrift 0.9.1 in 2013.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/thrift/thrift.mk

index 8a284229a1e24223f7275dbb815e03065e647e5a..6014bbfcdd4f646c7617392484484f4436726222 100644 (file)
@@ -31,8 +31,6 @@ endif
 
 # thrift doesn't use the regular flags BUILD_{STATIC,SHARED}_LIBS
 ifeq ($(BR2_STATIC_LIBS),y)
-# openssl uses zlib, so we need to explicitly link with it when static
-THRIFT_CONF_ENV += LIBS=-lz
 THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=ON -DWITH_BOOST_STATIC=ON -DWITH_SHARED_LIB=OFF
 else ifeq ($(BR2_SHARED_LIBS),y)
 THRIFT_CONF_OPTS += -DWITH_STATIC_LIB=OFF -DWITH_BOOST_STATIC=OFF -DWITH_SHARED_LIB=ON