package/cegui: force libglew when libepoxy is also enabled
authorBartosz Bilas <b.bilas@grinn-global.com>
Tue, 28 Apr 2020 19:58:43 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 29 Apr 2020 20:41:50 +0000 (22:41 +0200)
Cegui doesn't allow to have enabled both opengl libraries so disable
libepoxy when both are enabled.

Fixes:
  - http://autobuild.buildroot.net/results/2881bbcc2dcfcaa5ed663817ff39f7574430ba5a/build-end.log

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cegui/cegui.mk

index 673340194a5aec045bfe679823de193f3fa82df8..9640a15116804875e3eb65e19169393b2b6c66b2 100644 (file)
@@ -19,7 +19,8 @@ CEGUI_DEPENDENCIES = glm \
                $(if $(BR2_PACKAGE_LIBGLEW),libglew) \
                $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
-ifeq ($(BR2_PACKAGE_LIBEPOXY),y)
+# libepoxy support cannot be enabled together with libglew
+ifeq ($(BR2_PACKAGE_LIBEPOXY):$(BR2_PACKAGE_LIBGLEW),y:)
 CEGUI_DEPENDENCIES += libepoxy
 CEGUI_CONF_OPTS += -DCEGUI_USE_EPOXY=ON
 else