package/tor: add systemd optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 12 Jan 2020 19:04:21 +0000 (20:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jan 2020 21:25:20 +0000 (22:25 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/fa5f8506866451f40eb5f548c1099ae931b26fcc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tor/tor.mk

index 2ecb41f0729ee0d7d33b36f761f5da6bd68a1f83..0b41897b853766d3897e69bf711d030dbe2738d1 100644 (file)
@@ -30,6 +30,13 @@ ifeq ($(BR2_PACKAGE_LIBCAP),y)
 TOR_DEPENDENCIES += libcap
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+TOR_CONF_OPTS += --enable-systemd
+TOR_DEPENDENCIES += host-pkgconf systemd
+else
+TOR_CONF_OPTS += --disable-systemd
+endif
+
 ifeq ($(BR2_PACKAGE_XZ),y)
 TOR_CONF_OPTS += --enable-lzma
 TOR_DEPENDENCIES += host-pkgconf xz