systemd: clear telinit path
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Nov 2020 21:06:02 +0000 (22:06 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Nov 2020 21:17:55 +0000 (22:17 +0100)
Since we don't enable sysv any support, it makes no sense to set the
path to telinit either.

The path we were setting was anyway wrong: we set a path into
TARGET_DIR, but this path is only used at runtime, on the target, where
TARGET_DIR doesn't exist (it should have been /usr/sbin/telinit).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/systemd/systemd.mk

index 50416cceb61df6720b4370dbed409041df5c8ecb..63885993dbf8ad5fd169dd79ba752462af243526 100644 (file)
@@ -36,7 +36,7 @@ SYSTEMD_CONF_OPTS += \
        -Dsplit-usr=false \
        -Dsystem-uid-max=999 \
        -Dsystem-gid-max=999 \
-       -Dtelinit-path=$(TARGET_DIR)/sbin/telinit \
+       -Dtelinit-path= \
        -Dquotaon-path=/usr/sbin/quotaon \
        -Dquotacheck-path=/usr/sbin/quotacheck \
        -Dkmod-path=/usr/bin/kmod \