package: add webrtc-audio-processing library
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 May 2012 22:28:07 +0000 (00:28 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 May 2012 23:57:09 +0000 (01:57 +0200)
Optional dependency to pulseaudio >= 2.0

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/webrtc-audio-processing/Config.in [new file with mode: 0644]
package/webrtc-audio-processing/webrtc-audio-processing.mk [new file with mode: 0644]

index 359ba4759d9ce6cc2e55bb12f26e56d9ffcf363a..360f04fe8e51d8bede761148f144da134f30ab5f 100644 (file)
@@ -288,6 +288,7 @@ source "package/portaudio/Config.in"
 source "package/speex/Config.in"
 source "package/taglib/Config.in"
 source "package/tremor/Config.in"
+source "package/webrtc-audio-processing/Config.in"
 endmenu
 
 menu "Compression and decompression"
diff --git a/package/webrtc-audio-processing/Config.in b/package/webrtc-audio-processing/Config.in
new file mode 100644 (file)
index 0000000..e33fc57
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING
+       bool "webrtc-audio-processing"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         AudioProcessing library based on Google's implementation of
+         WebRTC.
+
+         http://freedesktop.org/software/pulseaudio/webrtc-audio-processing/
+
+comment "webrtc-audio-processing requires a toolchain with C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/webrtc-audio-processing/webrtc-audio-processing.mk b/package/webrtc-audio-processing/webrtc-audio-processing.mk
new file mode 100644 (file)
index 0000000..22ade1a
--- /dev/null
@@ -0,0 +1,10 @@
+WEBRTC_AUDIO_PROCESSING_VERSION = 0.1
+WEBRTC_AUDIO_PROCESSING_SOURCE = webrtc-audio-processing-$(WEBRTC_AUDIO_PROCESSING_VERSION).tar.xz
+WEBRTC_AUDIO_PROCESSING_SITE = http://freedesktop.org/software/pulseaudio/webrtc-audio-processing/
+WEBRTC_AUDIO_PROCESSING_INSTALL_STAGING = YES
+
+ifeq ($(BR2_SOFT_FLOAT),y)
+WEBRTC_AUDIO_PROCESSING_CONF_OPT += --with-ns-mode=fixed
+endif
+
+$(eval $(call AUTOTARGETS))