package/libnice: drop gstreamer 0.10.x support
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Feb 2020 14:50:18 +0000 (15:50 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 8 Feb 2020 21:42:43 +0000 (22:42 +0100)
With the upcoming removal of gstreamer 0.10, the logic for building
libnice with support for it must go as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libnice/libnice.mk

index b5168f83edd9a225b2acb371257cba61889a1c76..8cbf0035295cc48e9bd6919c8decb5a7bf2bd65d 100644 (file)
@@ -10,6 +10,7 @@ LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
 LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
 LIBNICE_DEPENDENCIES = libglib2 host-pkgconf
 LIBNICE_INSTALL_STAGING = YES
+LIBNICE_CONF_OPTS = --without-gstreamer-0.10
 
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 LIBNICE_CONF_OPTS += --with-crypto-library=gnutls
@@ -21,13 +22,6 @@ LIBNICE_CONF_OPTS += \
 LIBNICE_DEPENDENCIES += openssl
 endif
 
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
-LIBNICE_CONF_OPTS += --with-gstreamer-0.10
-LIBNICE_DEPENDENCIES += gst-plugins-base
-else
-LIBNICE_CONF_OPTS += --without-gstreamer-0.10
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
 LIBNICE_CONF_OPTS += --with-gstreamer
 LIBNICE_DEPENDENCIES += gst1-plugins-base