The clean target should really work.
author"Steven J. Hill" <sjhill@realitydiluted.com>
Tue, 17 Jul 2007 00:24:54 +0000 (00:24 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Tue, 17 Jul 2007 00:24:54 +0000 (00:24 -0000)
package/thttpd/thttpd.mk

index 58a1f9d3866f292e2cd749f450a6141137e78cf1..3c676d18cc98dd171a6072ad258aa9a622be973d 100644 (file)
@@ -61,6 +61,13 @@ thttpd: uclibc $(TARGET_DIR)/$(THTTPD_TARGET_BINARY)
 
 thttpd-clean:
        rm -f $(TARGET_DIR)/$(THTTPD_TARGET_BINARY)
+       rm -f $(TARGET_DIR)/sbin/httpd_wrapper
+       rm -f $(TARGET_DIR)/sbin/thttpd_wrapper
+       rm -rf $(TARGET_DIR)/var/www
+       rm -f $(TARGET_DIR)/etc/init.d/S90thttpd
+       rm -f $(TARGET_DIR)/bin/htpasswd
+       rm -f $(TARGET_DIR)/bin/makeweb
+       rm -f $(TARGET_DIR)/bin/syslogtocern
        -$(MAKE) -C $(THTTPD_DIR) clean
 
 thttpd-dirclean: