lpty: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:59 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:54:53 +0000 (16:54 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lpty/Config.in [new file with mode: 0644]
package/lpty/lpty.mk [new file with mode: 0644]

index 410971dfe6afb5b95753ce853bb67dcd04525133..fa9aaa0dc1d6d4b6abfd91c1feeba8c9a65693c5 100644 (file)
@@ -376,6 +376,7 @@ source "package/dado/Config.in"
 source "package/lbase64/Config.in"
 source "package/ljsyscall/Config.in"
 source "package/lpeg/Config.in"
+source "package/lpty/Config.in"
 source "package/lrandom/Config.in"
 source "package/lua-cjson/Config.in"
 source "package/lua-coat/Config.in"
diff --git a/package/lpty/Config.in b/package/lpty/Config.in
new file mode 100644 (file)
index 0000000..5e7ad14
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LPTY
+       bool "lpty"
+       depends on BR2_PACKAGE_HAS_LUA_INTERPRETER
+       help
+         A simple facility for lua to control other programs via
+         PTYs.
+
+         http://www.tset.de/lpty/
diff --git a/package/lpty/lpty.mk b/package/lpty/lpty.mk
new file mode 100644 (file)
index 0000000..0c3b7f9
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# lpty
+#
+################################################################################
+
+LPTY_VERSION_UPSTREAM = 1.0.1
+LPTY_VERSION = $(LPTY_VERSION_UPSTREAM)-1
+LPTY_SUBDIR  = lpty-$(LPTY_VERSION)
+LPTY_LICENSE = MIT
+LPTY_LICENSE_FILES = $(LPTY_SUBDIR)/doc/LICENSE
+
+$(eval $(luarocks-package))